Invisible symbols in schematic put footprints on my pcb (25.9 KB)

I am working on a design and saw several footprints which are invisible on the schematic. So I have uploaded my folder with all of the good stuff removed and only the phantom symbols, listed in the .png image.

I think this is a bug??

After my original report I resorted to editing the schematic file with a text editor to remove the phantoms. I do not like doing this (risky with my lack of software skills) but I am thankful that KiCad is open source!!

Application: KiCad (64-bit)

Version: (5.99.0-11430-ge61b1f03b8), release build

wxWidgets 3.1.5
libcurl/7.74.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19043), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Jul 14 2021 09:00:10
wxWidgets: 3.1.5 (wchar_t,STL containers)
Boost: 1.75.0
OCC: 7.5.0
Curl: 7.74.0-DEV
ngspice: 34
Compiler: Visual C++ 1928 without C++ ABI

Build settings:

You may have symbols well outside the main schematic area. Press the Home key. If the schematic is small, look out to the corners for additional symbols.

Or Annotate and look at the BOM for unwanted items, then use Control-F to find the part. Delete it.

1 Like

Thanks Barry

“Been there and done that”. Or at least I tried to. When you do “find” in Eeschema, cursor warps off page to blank space; no symbol is visible. I tried “Greedy select” window; trying to grab a rectangle starting from lower right. That does not find anything even though I have included the cursor warp-to location in the greedy grab rectangle.

Deleting the symbol using “notepad” text editor does work but I do not think that the developers are satisfied that I needed to do that.

Something very odd - I had a look with a text editor - apart from anything else, all the wires are width 0 and colour ( 0 0 0 0) as well as quite a lot of the symbols having a stroke width of 0, too. Not sure how the schematic would end up like this?

1 Like

Thanks, John

I created the schematic from scratch before deleting all of the normal stuff to post it on the forum. (The complete original schematic is under NDA.) So far as I can remember, I placed those symbols in a completely normal manner.

I do not know enough about the software to place symbols in any very abnormal way.

But I was able to search the ref des using the text editor, and then delete the entire symbol entry from the text file.

Just to say that this has happened again. I had a phantom “test point” component.

Here is the text entry for J9 from the ill schematic file. Note the “(at 11714.48 38.1 0)” which I think is nuts:

(symbol (lib_id “Bobs_Connector_Library:Test_Point_Keystone_5020”) (at 11714.48 38.1 0) (mirror x) (unit 1)
(in_bom yes) (on_board yes)
(uuid aa35001d-1263-4515-bb2e-1131e5563564)
(property “Reference” “J9” (id 0) (at 11715.115 39.116 0)
(effects (font (size 0.762 0.762)))
(property “Value” “Test_Point_Keystone_5020” (id 1) (at 11714.607 37.465 0)
(effects (font (size 0.762 0.762)) hide)
(property “Footprint” “Bobs_Connectors:Test_Point_Keystone_5020” (id 2) (at 11714.48 38.1 0)
(effects (font (size 0.762 0.762)) hide)
(property “Datasheet” “” (id 3) (at 11714.48 38.1 0)
(effects (font (size 0.762 0.762)) hide)
(pin “1” (uuid 3c4ae899-4b8c-4ade-b709-8dcc3a0ad13e))

Wild guess: did you create that footprint?
If yes, take a look with the FP editor and see where the pads are compared to 0,0

Your fp may be located out beyond the orbit of Saturn.

Your first wild H. A. guess is correct. But the single pad in the footprint is at 0,0. I use a bunch of them in the design and most are OK.

I have attached the 5.99 version footprint file.

Test_Point_Keystone_5020.kicad_mod (805 Bytes)

Did you ever discover the problem?

Thanks. No I did not.

I wonder if the symbol lib is corrupt. Have you looked with a txt editor? Not simple in a large flat file.

Well…I looked at that right now. The MMBT3904 is a “child” of my NPN_SOT23 and I was having difficulty to find that. So instead I looked at my Keystone 5020 test point which was the latest phantom. I do not claim to know enough to detect corruption. Here is the entry from my symbol library:

(symbol “Bobs_Connector_Library:Test_Point_Keystone_5020” (in_bom yes) (on_board yes)
(property “Reference” “J” (id 0) (at -0.635 0.508 0)
(effects (font (size 0.762 0.762)))
(property “Value” “Test_Point_Keystone_5020” (id 1) (at 0.127 -0.635 0)
(effects (font (size 0.762 0.762)) hide)
(property “Footprint” “Bobs_Connectors:Test_Point_Keystone_5020” (id 2) (at 0 0 0)
(effects (font (size 0.762 0.762)) hide)
(property “Datasheet” “” (id 3) (at 0 0 0)
(effects (font (size 0.762 0.762)) hide)
(symbol “Test_Point_Keystone_5020_0_1”
(circle (center 2.54 0) (radius 0.5334) (stroke (width 0)) (fill (type none)))
(symbol “Test_Point_Keystone_5020_1_1”
(pin bidirectional line (at 0 0 0) (length 2.54)
(name “~” (effects (font (size 0.254 0.254))))
(number “1” (effects (font (size 0.254 0.254))))

Sorry. No habla symbol files. Can you do a comparison to a standard symbol?

What does it look like in the symbol editor?

seems a bit odd - are you seeing the ref des but no connection point?
If this is occurring in different libraries i wonder if the preferences are corrupted?

In my schematic: I see nothing related to the symbol. If I CNTRL-F to find the symbol, the schematic editor warps to blank space.

This is a view from the symbol editor. I have moved the text so that it does not obscure the symbol.

If I were to probe this question with a text editor, where should I look?

My guess is that neither one of us is good with either symbol files or Russian language. :slight_smile: I can do a comparison, but if I compare the genes of a human with those of a carrot, I imagine I would find many differences. But which difference is the problem?

Another issue: In the wake of this problem, (at least for my library of bipolar transistor symbols) I have been deleting most of it; those which I had imported from the KiCad standard. Does NIH stand for National Institute of Health? No…here it means…“not invented here”. But really I like to delete the circle envelopes which I find just add clutter, as well as the references to standard footprints with small pads. I like to reduce the pin length, usually to 50 units. I like to refer to my own footprints with oversized pads for my clumsy hand soldering. I have backup copies of the symbol library which I could re-install but I am reluctant to risk disaster by playing with it too much.

Bob, I strongly suggest you use just the standard libs and get a valid schematic. Every CAD tool has unique characteristics. There are numerous little things I would change, but they don’t annoy me enough to do something about it.

As there have not been other reports from users having this difficulty, I believe it is a self-inflicted injury.

Please try again with standard libs. Later you can try swapping out for your own symbols, 1 at a time, and see what happens.

1 Like

Thank you. I know that you are writing from your sincere best judgement. However:

  1. I seem to have a valid schematic. Yes I had some issues with these phantom symbols but think I have eliminated them so that my schematic and board appear to be OK. These phantoms were an annoyance but they did not cost me that much time to resolve. If this keeps raising its ugly head maybe I will get some ideas about it. I do have one idea…that there was some recent migration between 5.99 versions and I think the format of the symbol libraries were converted. So maybe this is a disturbance which happened as a result of library conversion and it will fade away over time. I think that might be less work than starting with standard libraries and making them my own again.

  2. I am too dang stubborn in my dislike of the standard symbols. Text is too big, pins are too long, footprint references are not mine, there are bad URL links (such as pages at Fairchild Semiconductor) and I think that the circles around the transistors are mostly unnecessary clutter that is a carry-over from the days of vacuum tubes. (There may be some exceptions where the circles help to define a darlington transistor for example.)

Hi Bob,

How old is your 5.99?

I’m not sure how to interpret the windows information at the top of this thread.

I am sympathetic to that. I do not know how to interpret that stuff either. I download the latest 86_64-lite version. I keep my last few downloads so it will be easier if I want to revert.

My last download was on July 14. kicad-msvc.r23288.e61b1f03b8-x86_64-lite

My previous download was on June 27. kicad-msvc.r23019.70ac70f360-x86_64-lite

If I remember correctly there was some sort of format change in the symbol library when I installed and started using that July 14 download.

I’d thought maybe the problem was something between windows/5.99/5.99 libraries, but your version is only three weeks old, so I doubt that.