Invalid drill file at the Seeedstudio gerberviewer

I’ve just finished my project, but after I uploaded gerber files onto the Seeedstudio, I’ve encoutered a problem.
I checked files using their Gerberviewer and noticed that my drill holes were placed in the top left corner totally out of the PCB area.Holes were misplaced and also shrinked.
Gerber files were made following instructions at for Kicad.
I also checked those gerber files by Gerberviever provided by Kicad but there was no such a problem. I checked it with two online gerberviewers, one had the same problem, the other didn’t.

I compared drill file with a file from my old, successfully finished project and I noticed that my new drill file has additional line “FMAT,2”.
I simply deleted that line, upload it, and problem has finally disappeared. PCB now seems perfectly fine.

Is that a correct way to solve that problem? Or Have I missed something? Have I broken some rule or standard?

Versions of kicad are 4.04 and 4.06, OS Fedora25



Please provide the link!

What option did you select for “Zeros format” in the Plot drill file dialog?

Instructions for Kicad:

Zeros format is “Suppress leading zeros” (according to the instructions above).


1 Like

I tried uploading a recent project I created with 4.0.6, and it looks Ok. Maybe some difference due to locale or something.

I’ve seen this problem before I came to Kicad but it’s been a while and I don’t remember the details. That means either Eagle or gEDA at the time. Since you fixed your problem I’m sure neither of us will spend much time searching it on the net though. :wink:

Did find this quickly enough though:

I think this one mentions size and position:

Anyway, I ordered PCB.
I hope that my “fix” will work… and I’ll inform you about results.

Thanks guys and happy new year.


@djuka Hello,

Have you received your order? Any problems?

I am experiencing the same issue here. The seeedstuido gerber viewer shows me the exact problem you had.
I am not the designer and have no idea how to solve the issue.
I tried deleting the line you mentioned in your post but it did not work for me.

Any comments?



I just had this problem too. My fix was to change the zeros format in the drill file from “suppress leading zeros” to “decimal”. Looking at the drill file, I’m not seeing leading zeros anyway. The boards are ordered so I should know in a couple weeks.

Follow-up here. Yes, the boards I received from using “decimal” for the zeros format were good. So, until the code changes again, that seems to be the option that works with SeeedStudio. By the way, I’m using 4.0.7 on Linux.