Interactive Html Bom Plugin for KiCad 5.0


#101

Thank you for version 2. I’ve been designing circuits for over 40 years and using various CAD tools for 33 years and this is one of the few utilities that has made me go “Wow, that’s brilliant!” The addition of the extra fields for manufacturers’ part numbers is the icing on the cake that makes this truly useful in the design, purchasing and production flow. Thank you for your dedication and generosity in developing and sharing this.
Just one thing, I now have two iBOM buttons; does anyone know how to lose the redundant one? (KiCad V5.0.0.0)


#102

Check if you have 2 plugins installed (placed at the KiCad’s folders) and check Preferences>>Preferences…>>Pcbnew>>Action Plugins in the Pcbnew software.


#103

Glad you find it useful.

That’s weird, are you sure you don’t have the plugin in 2 different directories?

That is only available in nightlies, not 5.0.0.


#104

Ah, my fault then. Being a conservative type, I just renamed the folder of the older version thinking that would make it inaccessible. Deleting the old folder fixed it. Thanks. Should have thought of that myself really.:blush:


#105

Yup, the way KiCad plugin system works is it picks up anything in some predetermined set of directories that declares itself as a plugin. There is no deduplication or additional processing of any kind.


#106

I love this. Thanks very much.


#107

Some of the silk prints have been offset.


#108

Hm, that’s interesting. Can you send me the board? Feel free to delete everything (tracks, components) except those silkscreen markers and board outline.

Also curious why mounting holes don’t render. Are you on KiCad 5?


#109

TFPG.rar (643.3 KB)
This is project.used kicad v5.0.2.1
the mounting holes are VIAS+MASK.not footprint,So it doesn’t show.
I am a Chinese, using translation software, some words are not accurate.


#110

Thanks for the bugreport, I can reproduce this, which helps a lot. I’ll investigate why this happens.

Aaaand… I figured it out. For “5” and “8” markers there is an empty new line at the end of text. If you edit that text and select all you will see it. For some reason KiCad ignores empty line in the end, my plugin doesn’t. I’ll fix that.

Update: fix pushed to github.


#111

I’m about to hand-assemble a PCB, and so I’m very interested in this helpful plugin. However I can’t get it to work from Linux command line (on an OpenSUSE Tubleweed box). Sorry, I’m a complete python noob…

Here’s what I get using the V2.0 release of the plugin:

<my prompt> python2 ./bin/InteractiveHtmlBom/generate_interactive_bom.py --show-dialog
/usr/lib64/python2.7/site-packages/wx-3.0-gtk2/wx/_core.py:16629: UserWarning: wxPython/wxWidgets release number mismatch
warnings.warn(“wxPython/wxWidgets release number mismatch”)
Traceback (most recent call last):
File “./bin/InteractiveHtmlBom/generate_interactive_bom.py”, line 12, in <module>
import dialog
ImportError: No module named dialog

Is this a problem with my OS’ wxWidgets installation? It appears my wxWidgets packages are version 3.0.4, while a package called python-wxWidgets-3_0 is on version 3.0.2?


#112

No, judging by the error python can not find dialog module that is part of my plugin. Can you verify that dialog folder is next to generate_interactive_bom.py and that dialog has __init__.py in it?
When you install the plugin you need to unpack the whole directory and keep it together when you move it around.


#113

Indeed, my silly mistake… I didn’t recreate the folder structure when decompressing, so all files were in the same directory. The plugin worked straight away after I fixed that, even from within kicad 5.0.1…
Thanks for this excellent tool, and the quick support!


#114

You are welcome

That’s what you get for great description of your issue. You included error message, versions of your platform, packages, kicad. I wish everyone did that.


#115

I also wanted to thank you @qu1ck for a fine plugin - it works very well. I installed on 5.0.0 on my Hackintosh (Sierra 10.12) and works fab (I say that with jazz hands lol).

I’m a little slow, and took me a bit to figure out I didn’t even have a ‘plugins’ directory, Created one and moved the plugin folder to the correct location, restarted KiCad and voila… awesome.

So thanks for all the work and sharing with the community.


#116

Hi qu1ck, first of all, thanks a lot for investing your time in such great tool, it really helps when manufacturing as it simplifies cooperation (everybody has a browser now a days).

I wanted to report a small bug or strange behavior.

In my BOM i have two types of mosfets (P and N) , when I try to filter for the word “MOSFET” it only shows me the first instance.

The two types of mosfets:

using the filter

In general, filtering seems to randomly choose some parts and ignore others.

Still your tool is amazing and I’m only trying to point out this behavior.


#117

Thanks for the bug report, I just pushed a fix to github.

Filtering didn’t “randomly” not work, it just didn’t process extra fields. Highlight in extra fields worked however, which could cause confusion.


#118

Just want to say thanks for this great plugin! Just tried it out for the first time. It makes it sooo much easier to hand-solder for me. I’ve been using printouts and search in pcbnew up till now and ticked them off one by one, but oh my is this better. The highlighting map is just so great! Using this very moment

I think I doubled my speed :slight_smile:


#119

Hey, congrats @qu1ck, @ChrisGammell just posted a Contextual Electronics video about this plugin. Check it out here:


#120

That’s a great intro, thanks @ChrisGammell.
Any chance you would update that video with v2 of the plugin? I think explaining basics of how to add extra fields would be helpful. I would like to link this video on github, with your permission of course, but if you will update it I’ll wait for newer one.