Installing KiKit

When I look at the instructions on Github to install KiKits is says to open the kicad Command Prompt , I have no such facility on my Windows install ( Kicad V6 )

How do I proceed ?

It should be in the windows start menu under Kicad 6.0.

image

1 Like

nope Ive nothing there ( I do have it under V6,99)

I have reinstalled V6 and still no command prompt

How about in “C:\Program Files\KiCad\6.0\bin\kicad-cmd.bat”?

Here it is completely:

@REM This program source code file is part of KiCad, a free EDA CAD application.
@REM
@REM Copyright (c) 2021 Mark Roszko <mark.roszko@gmail.com>
@REM Copyright (c) 2021 KiCad Developer Team
@REM
@REM This program is free software; you can redistribute it and/or
@REM modify it under the terms of the GNU General Public License
@REM as published by the Free Software Foundation; either version 3
@REM of the License, or (at your option) any later version.
@REM
@REM This program is distributed in the hope that it will be useful, but
@REM WITHOUT ANY WARRANTY; without even the implied warranty of
@REM MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
@REM General Public License for more details.
@REM
@REM You should have received a copy of the GNU General Public License along
@REM with this program.  If not, see <http://www.gnu.org/licenses/>.

@echo off

@REM Get KiCad exe version to reproduce
for /f "USEBACKQ" %%a in (`powershell -NoProfile -Command ^(Get-Item "kicad.exe"^).VersionInfo.ProductVersion`) do set kicadVersion=%%a

@echo ************************************
@echo * KiCad %kicadVersion% Command Prompt
@echo ************************************

@REM We assume this script is located in the bin directory
set _BIN_DIR=%~dp0
set _PYTHON_SCRIPTS_DIR=%_BIN_DIR%Scripts

@REM Now adjust PATH to gurantee our python/pip executables are found first
set PATH=%_BIN_DIR%;%_PYTHON_SCRIPTS_DIR%;%PATH%
set PYTHONHOME=%_BIN_DIR%

@REM We patch python into utf8 mode by default because kicad is utf8 heavy
@REM But let's just add extra insurance
set PYTHONUTF8=1

@echo You may now invoke python or pip targeting kicad's install

cd /d %USERPROFILE%\Documents\KiCad\%kicadVersion%

set _BIN_DIR=
set _PYTHON_SCRIPTS_DIR=

exit /B 0

And here is the Start menu command:

%comspec% /k "C:\Program Files\KiCad\6.0\bin\kicad-cmd.bat"

I’ll add it into my V6

I have no Python interpreter loaded on my Windows, do I need a seperate Python install , and if so what version . thanks

I get a “No module named site” error when I run pip

This KiCad Command Prompt exists only because KiCad on Windows has its own python interpreter. If you run pip in this KiCad Command Prompt window the python which comes with KiCad is used. Pip which you run there installs packages for this KiCad python installation only and shouldn’t interfere with a possible system wide python installation if the user happens to have one.

But I wonder how you can have a v6 KiCad installation which doesn’t have the command prompt. Maybe it differs in some other ways, too, with a default installation?

Well I copied the command script out of the V6.99 nightly , and into the V6 release and ran it. ( just in the default bin dir)

It ran but when I type pip in get the error message , this usually means no Python.

I have v5.x , V6 release and V6.99 nightly in different directories. Only V6.99 has the Kicad command prompt present.

Where did you get v6 from? Are you sure you have v6 and not an RC which predated final release? Post full version info.

Yes I’m sure I’ had RC2 acid inupdrafer that to B6 release that script did not install