Installed v6 and have no symbols / 3dmodel etc

Coming from v5 I installed Kicad 6. I install the full package.

Now when I open kicad I can not see any symbols of 3d models or anything from the libraries.

This is on ubuntu. Any ideas what it might be? Is my previous version 5 interfering here? (v5 is no longer installed).

These are my path in schematic.

Opening an existing project I realised all footprint have their 3d model missing. In the property window it shows the 3d model path with a red cross.

I notice the KSYS3DMOD is no longer defined in the path. Does KICAD6_3DMODEL_DIR replaces it? But again this one points to a folder that does not exists.

Where are the 3dmodels when installing on Ubuntu?

Any help really welcome.

My version below

Application: KiCad PCB Editor

Version: 6.0.1-79c1e3a40b~116~ubuntu20.04.1, release build

wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-96-generic x86_64, 64 bit, Little endian, wxGTK, xubuntu, x11

Build Info:
Date: Jan 15 2022 20:26:22
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OCC: 7.5.2
Curl: 7.81.0
ngspice: 31
Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:

Ok. Loaded version 5 back now and I can see all my libraries fine.
But now all the project I opened with v6 won’t open. Nightmare!!!

Making some progress. I installed v6 on another machine that is virgin from any kicad install. Using same OS xubuntu. All fine this time I can see all libraries in here. Including symbols and 3d models.

The problem seems to be on the machine that had v5 before.

How can I remove anything from v5 and not have it interfering with the v6 installation?

Wait a second, I’ll find the answer from another thread…

EDIT: 3D Models do not show anymore - #2 by eelik

1 Like

Thank you but not exactly the same problem. I am still looking for a solution.

How do I remove all of v5 to install v6 as if it was fresh from any previous installation?

Edit. Sorry you are not on windows, but maybe this thread helps still…

I had another try today. I uninstalled kicad with

sudo apt-get remove --purge kicad

Then deleted some remaining files:
rm -rf /home/user/.cache/kicad
rm -rf /home/user/.local/share/kicad
rm -rf /home/user/.config/kicad

Same problem again.

How do I completely wipe out V5 to have V6 running normally on ubuntu?
Same OS with no prior existence of kicad had installed v6 fine and did not present the problem above. Do I really have to re-install my OS to be able to run v6?

“KIKAD_SYMBOL_DIR” is called an “environment variable” on windows, it can be removed by opening properties of “this pc” very easy. How do jou edit that on linux?

You should delete that (a leftover from kicad v5) and install full (not lite), 1.5Gb size kicad installer which will cleanly install new libraries. Google on how to edit (remove) environment variable on linux.

Edit: eelik is right!

It was a problem with v4 Windows installer that it installed the environment variables to the Windows user environment. The same hasn’t happened on Linux, so that should have nothing to do with this. The messages tell that the problem is an old library table, I don’t know how if the old configuration was deleted. Unless there’s a project local library table in an old project which points to global libraries. @bitswap, please check if that’s the case.

1 Like

…and back at this again. Thank you for the comments guys.

So I uninstalled v5 once more.
sudo apt-get remove --purge kicad

then check the envs:

env | grep -i kicad

Some left over indeed. Rebooted the machine. Then did it again.

env | grep -i kicad
Nothing back this time. (had some hope here).

Installed v6

sudo apt install --install-recommends kicad

Create a fresh new project. Same problem.

On the machine where I installed kicad from a virgin setup the content of the /usr/share/kicad folder is different.
On the previously v5 installed machine:

ls /usr/share/kicad/
demos library modules plugins resources schemas scripting template

On the kicad virgin machine:

ls /usr/share/kicad/
3dmodels footprints resources scripting template
demos plugins schemas symbols

The first one must be a v5 content does it?

I have not involved any already existing project for now. Just installing the v6 and making a fresh new project every time to test it.

Some progress but still not working. I found that the uninstall did not remove the libs symbols etc packages so I ran

sudo apt-get remove --purge kicad-demos kicad-doc-en kicad-footprints kicad-libraries kicad-packages3d kicad-symbols kicad-templates

Then installed v6 again. Was a longer install this time. Some progress as now the /usr/local/share folder looks right.

ls /usr/share/kicad/
3dmodels demos footprints plugins resources schemas scripting symbols template

but the problem is still the same although the paths points to something that exist.

The only issue with this now I might be able to revert back to v5 to work on my designs. What a pain!

That’s correct. The behaviour of the package system is that dependencies are pulled in on install, but are not removed when depending packages are removed. To do that you need the autoremove command of apt. Actually IIRC the library packages are recommended, not dependencies so definitely not affected by removal of the main package.

It sounds like you need to delete the sym-lib-table and fp-lib-table files from your account’s config directory again and rerun kicad. It was probably created wrong when the older library packages were still in place.

Edit: just as a double check that you have the correct versions of the packages, do

sudo dpkg -l ‘kicad*’ | grep ‘^ii’

This will list all installed packages matching kicad*.

Because there’s no project specific table, this is the probable explanation. The official KiCad libraries ship with their own prebuilt library tables which KiCad tries to find from some default expected location and copy to the user config when KiCad (sch. editor and pcb editor) is run for the first time and the table files aren’t yet found in the user config. KiCad doesn’t check what version those default libraries and their table files are. If they are from v5, they use the old ${KICAD_SYMBOL_DIR} etc. variables. KiCad doesn’t check if they are defined in KiCad’s paths and if they point to the same place than where the tables were copied from.

The ubuntu packages don’t version the installation directories (unlike on Windows where the official installer installs to kicad\<version_number>\. Therefore it’s possible that a new version of KiCad finds old versions of libraries if the libraries weren’t updated at the same time.

You run into problems because your “workflow” seems to have been this:

  1. You had v5 and libraries installed, and user config for that.
  2. You updated KiCad but not libraries.
  3. You removed old config but still didn’t update libraries.
  4. The old library tables were copied to the new config.
  5. You updated the libraries, too, but didn’t start with fresh config.

Am I right?

Well initially I ran into problems because I simply followed the kicad installation page.
Uninstall v5 → Install v6 → Problem.

Now yes I have deleted some files in the effort to solve the problem. Is that the ones you mean in 3.?

rm -rf /home/user/.cache/kicad
rm -rf /home/user/.local/share/kicad
rm -rf /home/user/.config/kicad

Assuming the workflow you describe summarise the state of my machine what would you suggest to get me back on track?

Is any one else on Ubuntu uninstalling v5 and installing v6 going to suffer from the same?

1 Like

@eelik I must specify. The workflow is a consequence of the initial problem. Not the opposite.

Your first problem, the 3D models, was answered in my first post. Further problems are probably due to installing back and forth without never doing all the needed steps at the same time (installing all new packages at once and deleting old config).

Oh dear!

I confirm this entire thread focuses on only one same issue. It is presented showing different aspect of the problem but the underling problem is always the same. The uninstallation of v5 is not complete.
One might punctually solve some library problems but that’s only solving part of the problem and I don’t think this is the right approach.

Others on this forum have also complained about unclean uninstall. Someone seems to have solved it using some tools on windows to detect left over files. Not sure if we have the same sort of thing on ubuntu but I have spent too much time on this now. (plus I managed to get a ‘you must have broke it yourself’ type of answer in the end.)

It is then apparent that uninstall is not a top priority. Fine by me. I hoped I knew this earlier though.

I’ll stick with v5 until I re-install a new ubuntu OS on which I’ll then do the v6 switch.

My KiCad installation of V6 on Ubuntu Mate killed my V5 installation shortcuts. I’ve not yet looked under the hood to see what is still there.

And, yes, I have had the same issues that you have had with the default settings while installing KiCad V6.

Please upvote this issue: kicad libraries: add option to use v6 symbol and footprint libraries (#7889) · Issues · KiCad / KiCad Source Code / kicad · GitLab (filled it when migrated from v5 libraries to v6 full install on windows, I had some work to do manually, described algorithm in that issue).

Also see After Installing version 6 there are no symbols available. (#10255) · Issues · KiCad / KiCad Source Code / kicad · GitLab

Clearly that was me, but it doesn’t mean I blame you for the unclearness of the library system and possible difficulties with Ubuntu package system or KiCad packages. I tried to find out why this did happen, and what I said is (not necessarily exactly but as an idea) the most probable explanation. It’s pretty common with modern technology that if something needs two changes to make it work, you are destined to try one at a time, and it doesn’t work; or it needs one and you try two. It happens every one of us. I also tried to explain what needs to be done:

  1. Clear the user configuration (or only the library tables).
  2. Update all KiCad related packages.
  3. Start KiCad and choose to start with new configuration; choose the default option for the library tables when KiCad asks.

Doing step 2 only partially and trying things in an order which caused using the old library tables was probably the reason why the update process didn’t work for you.

Personally I think KiCad could do more to help the user with library setups. And it’s my honest opinion that the library setup – when the default doesn’t work for one reason or another – is the most difficult part of KiCad to understand.

1 Like