Install Kikit under KiCad 6.0.2

Hello,
i am using KiCad 6.0.2.
when I want to install a plugin via the extension management, KiCad freezes.
https://github.com/KiCad was added as path.
What else do I need to configure?
Greetings Klaus

Hi,

Click on the PCM
image
A window opens, fetching for repository. For this step to succeed, you must have git installed ( I don’t know if you get it automatically on windows when you install kicad )
Click manage


Check that you have the official repository, click Save.
image
If you had to make a change, close and restart kicad ( just to be sure ). Then reopen the PCM.

Search for your plugin, click Install
image
click “Apply pending changes”

you should get this window:

And you should be good to go.
If there is still a problem, what step are you at?

Doing this on Mac the Errormessage no Backend found.

Hello,
i have added the Path
KICADOFFICIALREPOSITORY → https://repository.kicad.org/repository.json
and GIT installed, the same Problem :wink:
Are there any LOG files in KICAD (Windows) where you can look if necessary?

KICADOFFICIALREPOSITORY only uppercase under Windows, blanks not allowd.
image

Update:
edit the File c:\Users\xxx\AppData\Roaming\kicad\6.0\kicad_common.json

“environment”: {
“vars”: {
“KICAD6_3DMODEL_DIR”: “f:\Files\KiCad\libs\3dmodels\”,
“KICAD6_FOOTPRINT_DIR”: “f:\Files\KiCad\libs\footprints\”,
“KICAD6_SYMBOL_DIR”: “f:\Files\KiCad\libs\symbols\”,
“KICAD6_TEMPLATE_DIR”: “f:\Files\KiCad\libs\template\”,
“KiCad official repository”: “https://repository.kicad.org/repository.json”,
“KICAD_USER_TEMPLATE_DIR”: “f:\Files\KiCad\libs\template\”,
“KIGITHUB”: “https://github.com/KiCad
}
},
the Path is now correct, the problem persists

That’s not how the repository paths are set or controlled

There are some instructions in the KiKit repository - have a look in the bug report section and search for macOS issues. Unfortunately macOS makes things difficult for users and the current way around the problem involves codesigning pcbnew. It’s not difficult but annoying and needs to be done after any updates.

Drinausaur wrote:
Check that you have the official repository, click Save.
image
i can’t set this in KiCad, so i use this way.
What do you think I should set correctly?

@: John_Pateman : I have already tried this with the installation of KiKit from the rerpository, unfortunately without success. That’s why I wanted to go this way now.

HI, all tried as you see,
in the end, KiCad deleted, everywhere. Registry cleaned, reinstalled, the problem remains.
What exactly must be the name of the path variable?
“KiCad official repository” I can’t enter, only capital letters and no spaces.
Greetings

Repository is not a path variable. Official kicad repository is in the config by default, unless you deleted it it should just work.

Everything from the beginning, all variables in the freshly installed state, problem persists

Can you explain clearly what is your problem and what exact steps you took? Including what buttons you press and what error messages if any pop up.

I have installed KiCad 6.0.1 on my Win 10 (X64) PC , so far all good. Create circuit plan and layout goes.
I wanted to install the plugin KiKit and click on the icon of the Extensionmangager and KiCad freezes.

The list of available plugins is not displayed, KiCad remains so.
Update to version 6.0.2 brought no change.
above tips tested, also no improvement.
Uninstalled KiCad, deleted directories, cleaned registry, reinstalled.
Problem persists

Do you have a direct internet connection or via some proxy?

Try changing the 3rd party path. Follow these steps:

  1. Open path configuration
    image

  2. Find KICAD6_3RD_PARTY variable and change its path to something that you know for sure is writable like d:\temp_kicad_3rdparty
    image

  3. Click OK, close KiCad.

Then reopen KiCad and try opening the plugin manager again.

Thank you for this. i have change it
image
I have additionally allowed KiCad.exe in the firewall.
Problem persists

Few more questions:
Do you have a direct internet connection or via some proxy?
Do you use antivirus software beside windows built in defender?
Does the “Keine Ruckmeldung” (not responding) message appear on the window immediately after the progress dialog pops up or after some time? Or maybe only after you press cancel (Abbrechen)?

direct Internet, no Proxy
No other Firewall. Only MS Defender

it works in win10 save mode with enabled networkdriver.
and now?

That means you have some software that interferes with network functions. Usually it’s an overzealous antivirus but since you don’t have one, I have no idea.

Hello friends,
I found it, it was not easy!
It worked with WIN10 in safe mode and network.
After longer tests with the network it became clear that a service is interfering.
So all personally installed services (Filzilla, Dropbox, Firebird and Hardcopy, Google … ) were turned off.
The extension manager could be opened suddenly.
Hardcopy( comfortable screen copier) does something. More precisely it is the service hcdll_ex_x64.exe.
The problem exists also with current version 2022.02.23
If someone has the same problem, please stop the service and it works.
I will inform Hardcopy about the problem.

Thanks for your support.