Install 7.0.5 error "Kicad is currently running"

Trying to install KiCad, windows 11. Deleted everything KiCad from Registry, Program files, restarted computer several times. Error said same thing when I tried to uninstall KiCad.

Somewhere in the past I think I’ve seen maybe not with KiCad this bizarre behaviour, and it turned out that the installer executable was named the same as the program it was supposed to install so of course there was an instance of it running.

Try renaming the installer before running it. Did you get it from the official download site?

PS: It’s actually 7.0.5.

Yes, direct from Kicad.
Tried rename file same error.

The installer does a check for these running processes:

!macro KiCadRunningProccessesCheck
  ${RunningProcessCheck} "kicad.exe" $(APP_NAME_KICAD)
  ${RunningProcessCheck} "pcbnew.exe" $(APP_NAME_PCBNEW)
  ${RunningProcessCheck} "eeschema.exe" $(APP_NAME_EESCHEMA)
  ${RunningProcessCheck} "pl_editor.exe" $(APP_NAME_PLEDITOR)
  ${RunningProcessCheck} "pcb_calculator.exe" $(APP_NAME_PCBCALCULATOR)
  ${RunningProcessCheck} "bitmap2component.exe" $(APP_NAME_BITMAP2COMPONENT)
  ${RunningProcessCheck} "gerbview.exe" $(APP_NAME_GERBVIEW)

Use the Windows Task Manager to see if something is running in background.

1 Like

Only thing found was in details of Task Manager. Suspended but can’t delete. Even tried CMD to delete. Can’t delete?

I don’t use windows but search turned up this:

Which led to this which sounds promising:

Restart your PC lol

Tried CMD Taskkill. “Access is denied”

Tried CMD Taskkill “Kicad.exe” and PID#. Both access denied.

What is strange is that he said

KiCad itself doesn’t have any automatic start at Windows startup feature. So, if restart really doesn’t help, there’s something else going on.

Is this a personal computer or a work computer ? do you have full Admin rights ?

Personal computer, with Admin rights.

Yes restart, Kicad.exe still present in Details of Task Manager

Tried again to install with Admin same error.

Please don’t take this the wrong way . . . you are restarting your PC not just suspending or hibernating it ?

Try searching the whole drive for kicad.exe
Maybe there is some rogue programmed called this and it’s running.

Also try searching the registry for kicad.exe - something on the machine is starting this process.

Did actual restart and a shutdown.

Apart from some malware or something like that, we can only suspect there’s some autostart or autorun at work which can run arbitrary programs. Try to find out if KiCad has been added to some such list on your system. I could recommend Autoruns for Windows - Sysinternals | Microsoft Learn.

EDIT: and from the running process list you should be able to find out where’s the .exe is located. I’m not at Windows ATM but if the task manager doesn’t do it, you can try Process Monitor - Sysinternals | Microsoft Learn (also from MS sysinternals collection).

Success. GMC did the trick. Opened Registry as Admin. Did Cntrl F, to locate Kicad. Found four in odd places and deleted.

Thank you all


Yea the task manager photo showed an invalid description for kicad.

Either it’s “KiCad EDA X.X” (X=version) or “Installer for KiCad EDA Suite”.

So either way, quite odd