Initialisation problem on MAC

Screenshot 2021-01-07 at 6.45.00 PM

How can i start after this I’m finding no solution to this.

I do not understand.
What is the problem?

This is a normal question that KiCad always asks when it it started the first time after it is installed, and it asks you between different options to configure the global libraries.

I am a bit surprised that the default (recommended) is greyed out. This may mean that the default libraries are not installed. If you run Linux, the libraries can probably be installed as a separate package. If this does not apply then a complete removal (inclusive configuration files) and re-install may fix it.

If there is a fault in the global configuration, then I think that just deleting (renaming) the configuration directory will re-create it with the defaults if KiCad is started after that.

1 Like

It’s basically this: I installed KiCad 5 (under Linux) but there are no libraries. (The default option for sym lib table setup is disabled) but on Mac (at least the dialog looks like so; you should always tell the exact KiCad version and your OS). Did you follow the instructions in the installer?

2 Likes

yes ! I followed it

I’m using MAC Catalina and latest version of KiCad

I’m using MAC, can you suggest me how can I go further and what should I do to make the first option abled

Which Kicad version have you installed? Which installer have you used?
Did you copy the librararies to application support folder?
Installation on the Mac requires two steps.

please elaborate the second step, I think I have missed it.

As of I remember I pasted one kicad folder into the applications and other on desktop.

The other must go to application support.
There are links displayed in the right Window to both apps and application support folders.

1 Like

As I was copying kicad file to application support it wasn’t getting successful.
Basically wasn’t getting pasted to it.
So, I pasted the application support to desktop and then kicad to it.
And then proceeded with the third option of screenshot.
Is this right way ?
And what if I want to go with the second option ?

Starting from some point (I think 10.14) MacOS stops users from copying directly to application support from .dmg images. And of course the most “user friendly” OS does it just silently without any indication of user’s wrongdoing, because that’s the most intuitive thing to do… not.

The solution is to open Application Support in finder and drag the folder from kicad image to finder window.

1 Like

Yes! But it isn’t possible while the dmg is open.

Application Support is inside the macOS Library folder which is normally hidden. If you open a second finder window while pressing the ‘Option’ key it will show up. Drag the folder directly into your Application Support folder - You will be asked to authenticate.
You can get the Library folder to show up permanently by entering chflags nohidden /Library at a terminal prompt (or chflags nohidden ~/Library to do the same for the user Library)

An alternate way for macOS users to get at the Library folder quickly and without having to resort to Terminal commands:

To get to the Library folder, proceed as follows.
Open the Finder
Select the ‘Go’ menu and press and hold the Option key.
The Library menu will appear in this drop-down menu (only as long as the Option key is pressed)
While holding the Option key down, click on Library.
The Library directory will then appear.

Yes, it’s done now what to do ? I mean first option is still disabled.

You can always use the second option, Browse to the location where the libaries are and copy the sym-lib-table from there.

If you choose the third option you have to add the libraries later manually to populate the sym-lib-table.

Should I copy sym-lib-table from library to desktop and then select the pasted file from second option ?
Reply will be highly appreciated

I don’t use Mac so I can’t try myself, but the second option should work as long as the file is available to be selected through Browsing.

But this requires that the library files are available, too, and the path variables (Preferences -> Configure Paths) point to the right location.

Have you already tried all the other instructions given by different people above?

yes I tried
let me check this option too