Including fiducial info in .pos file

I can’t find a solution to have the fiducial position included in the .pos file. I’m using version 5.1.0-0
Any solutions for this issue? Thanks!

Edit: I actually can include certain fiducial footprints and others not, is it anything to do with the library? It’s a big problem I have 80+ designs here with 4 fiducials each, so any manual editing solution for each fiducial is a big pain.

POS file outputs SMD footprints. So you will want to mark your footprint SMD.


That works, thanks Seth_h! Is there any way this can be overridden or globally set or similar, as I have rather a lot of designs to go through and setting this for every fiducial is very annoying?

I’d set it in your footprint file and then update the footprints the identifier like this:

1 Like

Maybe we should add that this assumes you have the footprint in a personal library. If you change a footprint supplied with kicad inside the original library then your change will be overwritten on the next update. (or you lock yourself into the current library version.)

I think the official footprints are already set to Surface mount, no?

The ones i checked have (attr smd) so you might be correct here. (I did not check all of them)

We must have picked up an old footprint somewhere, how annoying… thanks for you help guys!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.