Including Drill Diameters in Gerber Files

I am using CopperCAM to process my PCB designs, and the software is able to accept Gerbers with drill info like hole diameters so you don’t need an excellon drill file. Is there a way to include all drill info in the gerbers in the latest version of KiCAD when plotting so you don’t need a drill file?

There is: PCB Editor / File / Fabrication Outputs / Gerbers / Generate Drill Files / Drill File Format / Gerber X2, and as you can see in the text message box in the screenshot below, this does greate .gbr files for the drills.

I’ve been using CopperCAM maybe 7yrs now - wonderful program!

These are my Kicad Export settings…

Results in CC

@paulvdh Thanks for the responses. A couple of notes:
When I export the drills as a gerber, I get holes that look like pads rather than the black dots that represent drills. If this is the best way to export drills, I’m not sure how to recognize the markings as drills. I want to avoid manually settings the pads’ drill sizes.

This is what I got from the CopperCAM support email:

I have a file with pads of the same size but different drill sizes, and it seems to me that CopperCAM isn’t reading the hole diameters from my drill file properly, as it is getting confused by the fact that pads of the same shape have holes of different diameters.

@BlackCoffee I am using about the same settings as yours, and they work well other than with this issue.

I don’t know whether this is a CopperCAM bug or not; when I use the ‘pads’ menu, the program highlights all the pads with the same shape and can’t distinguish between those with different hole diameters. When I use the ‘modify single pad’ button, however, I see all the hole diameters as designed in KiCAD. What do you all think?

I seldom have issues with CopperCAM(CC) but, when I do, Bertrand takes care of it quickly - I do have more frequent issues with Kicad and my own oversights/errors.

Here’s an example of CopperCAM indicating a Problem. It looks good in Kicad and it’s Gerber viewer but, when load into CC it shows a problem.
To solve the problem, I reviewed aspects that lead me to realize the Track wasn’t actually connected to the Pad’s Hole. Fixing it resulted in CC doing it correctly. I have a few more to fix now…

As far as Pads and Holes I see no problems - example screenshot shows only identical pad/holes selected - I did set some to be different for this test so it would be clear that only identical Pad and Hole get selected… I machined the PCB yesterday but tweaked it today so, I’m headed into the garage to re-mill it but first I guess it’s time for me to reset all my footprints and not be lazy…

Screenshot shows Pad/Holes with these dimension’s and CC correctly grabbed them. If anything is different, they’re not grabbed.
1.7 3 1
2.8 1.85 0.8
2.5 1.52 0.8
1.9 2.8 1

Very interesting. Well, I added the files here; would you mind please looking at it? My CC grabs pads that do not have identical holes.
LED (392.2 KB)

I apologize for misleading you!

Well, without looking at your file, I tested identical Pads but having different size holes - you’re correct. I don’t know when (or, ‘if’ ) this change was made - perhaps I was just dreaming.

Regardless (and my cop-out) is that when I change Pads, I don’t use the “Change All Identical Pad” tool. I use the “Change Shape From Another Pad”.

Regarding the ‘Holes’ in Pads… I’m lazy about making all of my footprints to have the same Pad/Hole sizes so, when I need to change Holes, I switch to the Drill Layer and “Copy From another Drill”

Also, worth noting: See any Gray Rings around Holes? That is controlled by the Selected Tool setup and is based on ‘Allowing Circular Boring’ - I usually keep it set to 1mm but change on a project basis as needed.

Ideally I don’t want to alter pads or drill holes after I import the drill file into CopperCAM. Do you know how to get CC to read the drill hole diameters correctly without any changes within CC? In the post above, it looks like you are changing drill diameters after you import to CC.

Good to know about the gray rings! Strange that I have my ‘Allow Circular Boring’ size to 0.5 mm and I don’t have any gray rings.

I don’t know ‘exactly’ what you’re doing. I changed only a couple of Drill diams for test.

I simply load New, grab the B-cu layer and after it loads, I Add the ‘Drills’. They load as designed in Kicad. No problem. screenshot shows the these two steps. You can see there are Holes of different sizes and two slots.

Aside issue - Kicad used to load my Jumper Wire with Pad perfectly fine. Now, only small round pad load for them (shown in screenshot). I’ll fix that by redoing the jumpers. Otherwise, all works fine… I even tweaked a few pads/holes in Kicad to see the results in CC.

File>Information gives info

IN FACT… Weird! Looking at my first post shows the jumper-wire pads. Now, they have small round pads??? Guess I need to grab coffee and think a bit…

EDIT: It looks like my jumper-wire Pad issue may be CC, though it was fine yesterday. Kicad’s Gerber viewer show them correctly today but CC doesn’t…

EDIT - Again… Solved: CC doesn’t like some of Kicad’s Pads (rounded-rectange, Chamfered corners…etc) .It does like Oval and Rectangle but may be problem if they are Angled at footprint placement (haven’t tried if ok setting angle of the Pad in footprint). I get what I need by Copy from another Pad.

In your design, do you have any pads whose size is the same but whose drill diameter is different? That’s the original issue, and it seems to me that I’ll just have to either manually set the drill diameters in CC or go back to KiCAD and make all pads with different drill diameters unique in their pad size.

Yes. Absolutely.

In fact, to demo/confirm for you, I just loaded two Parts ( three each) with same Pad but different size Drill Holes. (yes, I did change the Footprints for this demo). Thus, if you have Pads of same size but, with different size Holes, you should get the correct results in CC.

All of these Pads are 1.7mm X 3.0mm, each part with different size hole ranging from 0.5mm to 1.5mm.

Because I do Not have a Drill or Mill Bit in the Selected Tools Panel, the Pad with 1.5dia holes show as CC assumption of Routed holes because clearance is an issue (I could add a 1.5 bit to the tool list and not have this situation but, I wanted to demo it for you).

Summary: CC does the Correct thing based on Kicad’s geometry so, it’s up to User to set/create a manufacturable design.

I don’t know what your Kicad or CC setups are - that’s for you to dial-in but, as you can see, all is good, simple and without trouble. Nothing’s perfect but, currently, no problem…

If you need CC help with respect to using Kicad, you can PM me or continue posting in this/other links - just keep it relative to using Kicad :wink:

ADDED: To make it even clearer, see the Video below… shows what happens if using the correct Drill Bit - simply added it to the Selected Tools and, 'Bingo!"

In KICAD - as designed

As Loaded Into CC

CC Results

Hovering Over Pads in CC Shows Pad and Hole Size example show 0.5mm and 0.8mm holes… you get the idea…

I’m going to consider this Posting Closed.

I’m adding a final screenshot showing how I ensure CC minimizes the need for user tweaking (it does have good tools for setting/tweaking/Adding separators…etc).

But, I prefer to set my Footprint Pad’s to ensure the Bits I use/select will work without needing many tweaks.

Screenshot example of Pad sizing/bits… just for your reference…

Thank you very much for the help.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.