Impressed by Kicad, but

Hello everybody, this my first posting here.

I recently made the switch from Cadsoft Eagle V770 to KiCad 5.1.x (on Linux).
In order to speedup things, I attended to the online video course “Kicad Like a Pro 2nd ed.”.
It helped me a lot. I just finished my first project and I must say that I’m impressed by Kicad.
Specially the layout editor. Compliments to the KiCad team!

However, there are also some things I miss in Kicad or I don’t know how to do it.
Things that are easy with Eagle but not with KiCad.

There’s no ‘G’ (drag command) in symbol and footprint editor. Changing the width and height of a rectangle requires to manually edit and changes the coordinates of the two endpoints of all four lines.

There’s no ‘E’ (edit) command in symbol editor for circles and polygons. The only way to change the size of a circle is to delete it, set the grid to an appropriate size and try again.

There’s no possibility in the layout editor use a single line for keep-out (only areas).
So, instead of a line I need to draw rectangles/polygons.

It’s not possibility to select multiple objects (for a move) while not selecting an object in the midst of it (or de-selecting one or more objects from a group of selected objects),

After starting KiCad, starting the footprint editor takes 40 seconds on an old pc.
It takes 17 seconds on a brand new, high-end, workstation with an ssd.

Creating new symbol libraries by copying and modifying existing ones is cumbersome.
I found it easier to use a texteditor and manually copy and edit the files.

I like how easy it is to add and adjust a 3d (step) file to a footprint.

Overal, I like the Eeschema and PcbNew. Library management and creation is a disaster.
I hope it will be better with V6.

One other thing. Both with 5.1.7 and 5.1.8, I had some segfaults in a relatively short period.
This is extremely rare for me with Eagle V770 on Linux. It happened only once a year or so.

I just wanted to share my first experience with KiCad with you. Again, overal I’m positively surprised how far KiCad has come. Compliments for the team!

Disaster is a very strong word to use here.

I personally prefer how kicad is organized here compared to eagle.

Eagle in my opinion makes it too hard to have a well organized library that scales well. Mainly because footprints need to be in the same library as their symbols. So it is quite hard to organize the symbol lib by function while having a footprint lib organized by shape.
I just like the way i can share for example the SIOC-16 footprint between all possible parts that need it without needing to have all of them in the same library (So i can have my OPAs in one symbol lib and logic parts in another but all can point to the SIOC footprint lib)


I also don’t see how library creation would be a disaster at all. What is easier than “File->new symbol library”? (and the same exists on the footprint side)

My guess is you use a decentralized library setup (so libraries local to every project instead of having them shared between projects).
You might want to take a look at this then Project and libary setup for sharing and collaboration (KiCad version 5)

Could you please file bugreports for these (provided you can come up with a series of steps that lead to the crash)? Maybe your workflow is different than those the developers have tested.

1 Like

Can you edit your post and number the items?
That makes it easier to refer to them.
Half your issues are probably already fixed in V5.99. Circles and rectangles can be dragged and resized in both the Symbol editor and Footprint editor.
Selection has also already changed, by holding the [Shift] key and [LMB] you can toggle selection of individual items.

This may be related to a bug I experience too. See:


My current PC is a (probably first gen?) i7-860 and loading the libraries takes around 30s in KiCad V5.1.8, and about 5s in KiCad V5.99.
I never bothered to make a bug report for this.

Why do you find library management such a disaster?
It is a 2 step process. First you have to add libraries you want to use to the library table with: " … / Preferences / Manage Symbol Libraries and after that you can simply right click on a symbol, copy it and paste it in another library. Maybe you are having some difficulty because KiCad’s default libraries are read-only. Which is a good thing.

Writing “it is a disaster” does not help in any way. What are your issues with the library management, and do you have any suggestions in how it can be improved? Maybe you’re just overlooking something simple.

I agree with cedric here. New users sometimes find long standing bugs because they push on buttons in a weird order, or try do do unusual things. My experience is that if a bug is reproducible and reported properly, it often gets fixed quickly.

1 Like

Agreed. The bugs I’ve reported all have been fixed within 48 hours.

2 Likes

Hi,

The standard libraries etc. are installed in /usr/share/kicad/

My projects and private libs are organized like this:
(kicad is actually /data/private_name/kicad)

kicad/
  doc/
    *.pdf
    *.txt
  lbr/
    modules/
      *.pretty/
        *.kicad_mod
    models3d/
      *.step
      *.igs
    symbols/
      *.lib
      *.dcm
  projects/
    project1/
      *.pro
      *.sch
      *.kicad_pcb
      sym-lib-table
      *-cache.lib
    project2/
    project3/

All private libs are assigned “global”.

One bug that causes a reproducible segfault in 5.1.7 seems to be disappeared (solved?) in 5.1.8:

In Eeschema, when adding a device whith multiple gates, when adding the second gate, it segfaults.

Another (5.1.8) segfault: (this one happened a couple of times but suddenly I can’t reproduce it anymore, maybe I did something different…)

kicad[6209]: segfault at 79 ip 00007f445f50e54b sp 00007ffc071bfd08 error 4 in _pcbnew.kiface[7f445e91a000+10ef000]
Code: c4 08 5b 5d c3 66 2e 0f 1f 84 00 00 00 00 00 8b 8f 0c 02 00 00 85 c9 75 26 48 8b 06 48 85 c0 74 17 48 8b 40 08 48 85 c0 74 0e <8b> 50 28 85 d2 ba 00 00 00 00 48 0f 44 c2 f3 c3 0f 1f 44 00 00 31

start the footprint editor

open a footprint from the standard library

copy the the footprint by rightclicking on the footprintname in the list on the left

create a new library: File -> New library (/data/private_name/kicad/lbr/modules/test123.pretty) select “Global”

in the list on the left, click on test123, rightclick on it and paste the copied footprint

press ctrl+s to save the new lib

doubleclick on it to open it

open the fottprint properties editor

in the footprint properties editor, change the footprint name to cetriolo

in the footprint properties editor, change the value to cetriolo

click on ok to close the properties editor

press ctrl+s to save the lib

Another (5.1.8) segfault:

close KiCad completely

manually delete a private footprint lib e.g. rm -rf /data/private_name/kicad/lbr/modules/test123.pretty

start KiCad and start the footprint editor

It will complain about the missing lib, click on ok

Go to Preferences -> Manage footprint libraries and remove the entry of the missing library

Click on ok

then it segfaults:

traps: kicad[7847] general protection fault ip:7fb4fa81254b sp:7fff964117b8 error:0 in _pcbnew.kiface[7fb4f9c1e000+10ef000]

If I repeat the above procedure but without deleting the test123.pretty directory, it segfaults as well:

traps: kicad[7847] general protection fault ip:7fb4fa81254b sp:7fff964117b8 error:0 in _pcbnew.kiface[7fb4f9c1e000+10ef000]
kicad[8083]: segfault at 9c ip 00007fc7d17b954b sp 00007ffed677b948 error 4 in _pcbnew.kiface[7fc7d0bc5000+10ef000]
Code: c4 08 5b 5d c3 66 2e 0f 1f 84 00 00 00 00 00 8b 8f 0c 02 00 00 85 c9 75 26 48 8b 06 48 85 c0 74 17 48 8b 40 08 48 85 c0 74 0e <8b> 50 28 85 d2 ba 00 00 00 00 48 0f 44 c2 f3 c3 0f 1f 44 00 00 31

I’ll try to keep notes of erratic behaviour and I’ll try to make better descriptions of them.
But as you probably know, a segfault comes often at an unexpected moment and I can’t always remember all the steps involved that leads to the crash.

Anyway, it’s not my intention to come here and complain. Overal, I’m satisfied so far with the overal results I’m getting with KiCad.
At least it seems good enough to abandon Eagle.

Thanks!

You can shorten your routine a lot. Open the source footprint. Choose “Save as” from the file menu, enter the new name and select the target library. No need to open it up again unless you want to change something else than just its name.

I’ll try that, thanks!

Also at least in current nightly the footprint is then automatically opened with that routine. (I assume the same will happen with symbols)

I can’t use nightlies.
We are/were using Eagle at work for commercial projects.
Now we are considering to switch to KiCad and you will understand that we want to use the most stable version for that. I’m using openSUSE Leap at work and the latest stable version is 5.1.8 (correct me if I’m wrong).

The reason why i mention that i tested on nightly is not to try and get you to use nightlies but to give you all the information necessary to understand possible differences between what i see and what you see.

Sorry, I understood wrong :grinning: I need more coffee

That is worth repeating.

The whole editing system of schematics and symbols has been changed dramatically. Things can actually be selected like in about every other desktop software. You can use G and drag a side of a rectangle in the schematic editor. There exists real rectangle item in the symbol editor and in Pcbnew (i.e. the layout editor and in the footprint editor), with corner handles which you can drag with mouse. Etc.

This is possible in Pcbnew v5.1 using Shift+click. In 5.99 it’s possible in all editors using Ctrl+click.

This is a big problem, but mostly when you start a project for the first time. KiCad creates fp-info-cache file which caches information about footprints. Subsequent opening should be quick.

I don’t remember at the moment how 5.99 and 5.1 compare, I have 5.99 open right now, but at least you should try the right mouse button menu on the left hand list of symbols or footprints, and the File menu of the window. I believe some users may have missed especially the context menu.

Brilliant! Thank you very much :+1:

If now you ‘only’ considering to switch than probably before you switch V6 will be the current stable version. I have never tried V6 but as I have read here it is close to the state: ‘interface is frozen, any new considered possibilities moved to V7, and from now only bugs are to be fixed’. I am doing current projects so I suppose moving with them to V6 is not save but if I were only considering to switch to KiCad I would certainly start from V6 (5.99) to learn and switch when V6 will be stable.
I have switched to KiCad 3 years ago from my old Protel 3. There are some possibilities lacking for me in V5 and as I know they are in V6. The first example is that during placement I wont to hide GND connection lines (I use all bottom as GND) to see only connections I will have to do. In V5 it is not possible (without manually edit netlist file).

Version 6 might have its list of new features frozen, but it will be a long time until it becomes stable. At least a year. From what I have heard so far, important parts of kicad’s data architecture have also changed in version 6, hopefully for the better. But it will take a long time before it is stable enough for daily use with work-related projects, IMHO. This is natural and expected.

1 Like

I would not be so sure that it will be another year. The first release candidates of v6 are expected for early next year. So i suspect the 6.0 release to be sometime next summer. (V5 had a similar target for first release canditate and was released mid summer https://launchpad.net/kicad/5.0)

Hello,

after my donation via CERN they sent me an answer saying that V6 may be released “early 2021”
(maybe my incredible amount of money sped things up ? :wink: :wink: )

1 Like