Importing from Altium with Kicad Nightly 8.00 RC1.6

Good morning,
I tested importing schematics and PCBs from Altium and it doesn’t seem to work for me.
I am interested because I have files to import into Kicad because I abandoned Altium.
The import files must come from what version of Altium?
Kicad under W10 64 bits
THANKS
Fraçois

I do not have much experience with altium imports myself. I imported a few of the Nucleo boards from ST once and a few projects found either on the EEVblog or github and it always worked for me. I did a total of maybe 5 imports, but I never did much with any of those projects after the imports. It was mostly a test to see if importing worked. There are limits though. Best I know KiCad does not support all of altiums features, and for some features the import may work badly or not at all.

What is the nature of your problems? Maybe it’s not related to the files or the importer, but to the way you do the imports. If you upload one of the projects you have problems with, then there are several people here who are willing to do the import and have a look at problems. If you don’t want to share your own problems, you can use a random project (for example from github) as a reference so there is some common ground.

Good morning,
I put the schematic file of a power supply with which I am trying to import into kicad.
The diagram is very classic and can be public.
Have a good day

Alimentation.SchDoc (18.9 KB)

This schematic file does indeed not open for me.
I tried this by first starting Eeechema in “standalone” mode (That is without an active project). and then File / Import / Import Non-KiCad Schematic. These importers are not available when KiCad has an active project.

But as I wrote, it does not work for me either.
A short analysis:

paul@cezanne:~/downloads$ strings Alimentation.SchDoc 
DProtel for Windows - Schematic Capture Binary File Version 1.2 - 2.05
Times New Roman
	CAPACITOR
R-04
R-04
CAPACITOR-POL
HEADER 3
DIODE

and then comparison with a project that does work:

paul@cezanne:~/projects/arm/00aa_projects/00aa_motor/Dummy-Robot/1.Hardware/Controller$ strings Main.SchDoc |head -n10
|HEADER=Protel for Windows - Schematic Capture Binary File Version 5.0|Weight=1994|MinorVersion=2|UniqueID=QVBBULDQ
|RECORD=31|FontIdCount=11|Size1=10|FontName1=Times New Roman|Size2=10|Rotation2=90|FontName2=Times New Roman|Size3=10|Underline3=T|FontName3=Times New Roman|Size4=10|FontName4=Consolas|Size5=10|Rotation5=270|FontName5=Times New Roman|Size6=5|FontName6=Arial|Size7=8|FontName7=Courier New|Size8=5|FontName8=Courier New|Size9=14|Underline9=T|FontName9=Arial|Size10=10|Rotation10=180|FontName10=Times New Roman|Size11=36|FontName11=Times New Roman|UseMBCS=T|IsBOC=T|HotSpotGridOn=T|HotSpotGridSize=5|SheetStyle=1|SystemFont=1|BorderOn=T|SheetNumberSpaceSize=12|AreaColor=16317695|SnapGridOn=T|SnapGridSize=5|VisibleGridOn=T|VisibleGridSize=10|CustomX=1500|CustomY=950|CustomXZones=6|CustomYZones=4|CustomMarginWidth=20|Display_Unit=0
|RECORD=41|OwnerPartId=-1|Color=8388608|FontID=1|IsHidden=T|Text=*|Name=CurrentTime|ReadOnlyState=1|UniqueID=DJIXRFRS
|RECORD=41|IndexInSheet=1|OwnerPartId=-1|Color=8388608|FontID=1|IsHidden=T|Text=*|Name=CurrentDate|ReadOnlyState=1|UniqueID=DPHOGMVK
|RECORD=41|IndexInSheet=2|OwnerPartId=-1|Color=8388608|FontID=1|IsHidden=T|Text=*|Name=Time|ReadOnlyState=1|UniqueID=BGTJBPVO
|RECORD=41|IndexInSheet=3|OwnerPartId=-1|Color=8388608|FontID=1|IsHidden=T|Text=*|Name=Date|ReadOnlyState=1|UniqueID=QKEORCCO
|RECORD=41|IndexInSheet=4|OwnerPartId=-1|Color=8388608|FontID=1|IsHidden=T|Text=*|Name=DocumentFullPathAndName|ReadOnlyState=1|UniqueID=LEDWDDWJ
|RECORD=41|IndexInSheet=5|OwnerPartId=-1|Color=8388608|FontID=1|IsHidden=T|Text=*|Name=DocumentName|ReadOnlyState=1|UniqueID=APGDBRII
|RECORD=41|IndexInSheet=6|OwnerPartId=-1|Color=8388608|FontID=1|IsHidden=T|Text=*|Name=ModifiedDate|ReadOnlyState=1|UniqueID=EPKYLIPM
|RECORD=41|IndexInSheet=7|OwnerPartId=-1|Color=8388608|FontID=1|IsHidden=T|Text=*|Name=ApprovedBy|ReadOnlyState=1|UniqueID=RYQUAKNH

This comparison shows a relation. Both have the “Protel for Windows” string and the “Schematic Capture Binary file Version”. Your “Alimentation.SchDoc” claims to be a: “File Version 1.2 - 2.05”, while the file that does work for me has a: “File Version 5.0”. Therefore I suspect that the file you uploaded is from a very old Protel / Altium version. Is this correct? A simple thing you can try is to open the file in a recent altium version and then save or export it, and try again with KiCad.

The file I compared it with is (very likely) from this project: https://github.com/peng-zhihui/Dummy-Robot

Hi,
Yes, you have right, it’s an import in altium from Protel 99 SP6.
François

I’d suggest using the Protel99SE importer in a current Altium version. if you need it imported, send it to me…