Importing/converting old .mod footprints


#1

Hi There,

I have a .mod footprint which I want to use, so I used the Footprint Library Wizard to import it, and it said it imported correctly … (The footprint was converted by an eagle script)

If I now browse footprints, I see the library name, but no footprints … any idea’s how to fix this?

My Kicad version is a fresh git pull 2017-11-07 revision 7d24a576e-master.

Cheers,


#2

Create your own footprint?

It is not that hard, and is something every KiCad user should know how to do.


#3

If you are starting with an eagle library or layout, you could skip the eagle conversion script, and try converting into another format that Kicad understands and can import, like the gEDA PCB (.fp) footprint format

You can do this with

This will convert eagle XML libraries (.lbr) and also footprints embedded in XML layouts (if you change the layout file ending to .lbr),

It could be that eagle is using features that Kicad does not support within the footprint you are trying to use; for example, translate2geda can’t do much with SMD pads that are polygons that is compatible with gEDA PCB elements, and Kicad doesn’t like arcs on copper.

If you can get the footprint in BXL format, there is also

which can convert BXL defined components into gEDA .fp format footprints, gschem symbols, and also kicad eeschema symbol libraries.

Good luck!

Erich.


#4

@erichVK5
Many thanks, your response was very helpful :slight_smile:


#5

It seems kicad (nightly) should be able to import complete eagle projects.
That would mean it is not necessary to go via some external script.


#6

I am only wanting to import a library though … will nightly do those as well?


#7

If it can import a project a assume it can also import a lib. (I think footprint libs have always worked. Just add it via the library wizard and see what happens.)


#8

Hi, I tried that with an eagle footprint I found on snapeda. It “seemed” to import correctly and appears in the list of footprints, but when I view the footprint all I see is a blank page.

However if I use the translate2geda script and import that, it is fine. So I think there are still issues with directly importing eagle libs into kicad …

Also, when you use the wizard to import a footprint you are given the option to put it’s visability global or for the project. I would like to put the footprint in my own library, how can I do that? I don’t know where it puts it …

It doesn’t put it in the currently selected library … which would make more sense to me.

Cheers


#9

I successfully opened a lot of footprints created with eagle 6.5 with kicad 4.0.6. What version of eagle was used to create your footprint?

Kicad does not touch (change) the eagle lib it self. It simply understands the file format and can use the footprints included. (The only problem are things like keepout zones that do not yet exist in kicad and are simply ignored.)
If you want to save the footprint into one of your other libs do it as you normally do. Simply open the footprint in question with the footprint editor (lib browser or set the source repo as active)
After that simply set your target lib as active lib and press the save footprint to active lib button. (This step will create a kicad .pretty footprint)

The lib i used as a test:
con-hirose.lbr (32.2 KB)

In the library wizard:


Opening it in the lib browser:

And the footprint within the footprint editor:


#10

Hi,

I tried to use this footprint from SnapEDA for example:
https://www.snapeda.com/parts/AUR9718BGD/Diodes%20Inc./view-part/#download-modal

I tried both the Eagle and Kicad footprints from that page and they both are not visable in Kicad.

EDIT: I tried your attached footprint for the hirose connector, It won’t import either … it appears in the list of footprints with 4 parts but when I look at the part, is says it can’t find it.

Cheers,


#11

What kicad version do you use? Ok i saw in your first post you use self compiled.
Might be that your version has a bug with the eagle import. (They gave it more features.)

So you might want to create a bug report.


#12

What is your language setting? I wonder if it is a problem with locale setting again, since the footprint file has decimal points.


#13

Hm i just tested my file in ubuntu nightly. I get an error message that something is on an unsuported layer and that this got moved to dwgs user. Sadly it does not open the footprint. I don’t even get an error message.

I created a bug report here: https://bugs.launchpad.net/kicad/+bug/1731802


#14

@bobc My locale is: LANG=en_NZ.utf8

@Rene_Poschl Yep, I got the same error.

By the way, how do I delete footprints that have been added via the wizard? I don’t see anyway to clean up …


#15

you use the library manager to remove libs from the lib table. (This does not remove any files from your disk. Only the link from within kicad is removed.)
The manager is found in pcb_new (or footprint editor) under preferences.


#16

Thanks. Except it is now called “Footprint Library Table” which had me confused for awhile … :wink:
EDIT: … and I accidentaly deleted the link to one of the standard libraries … anyway to determin what it was and get it back. :frowning:


#17

getting back official libs is quite easy. simply start the library wizard and select github as source. At the second page you get a list of all available libs. (For nightly you even get libs that where created in the time since you first installed kicad.)


#18

Yes, but to save me reinstalling all of them, how do I get just that one back?

Also, probably would be a good idea to add a “Do you really want to delete xxx …” dialog to warn the userwhen any sort of delete is going on … for me, I did not even realize I had a lib highlighted at the time of pressing the delete button, I mistakedly thought that button would pop up another dialog …