Import the symbol and Footprint in KiCad 6


how can I correctly import the symbol and Footprint for Capacitance (C4) in KiCad 6 to avoid the PRC problem as you can see below :

You can find EDA-/CAD models under the following link:

Thank you very much!

Best regards,

Have you changed your grid setting from 50 mil? Kicad libraries are built on the 50 mil grid for legacy purposes. It helps ensure all parts line up and gives consistency to sizes. We like to think of the 50 as unit less because people seem to think they need to work in mm. It really doesn’t matter here.

@ hermit: I don’t think it’a a grid issue. There are no squares on the endpoints.

I’d say:

  1. Learn to use KiCad with just the default libraries. Build a few simple circuits and PCB’s, just to get to know KiCad.
  2. Learn to use the symbol and footprint editors Both to create new parts, and to be able to make modifications to existing parts.
  3. Only if you’ve learned the basics of attempt to use external sources such as ultralibrarian, snapeda, pcblibraries, Digikey libraries, etc.

Take it in small steps. Once you’ve learned the basics, it’s easy to expand on that. If you try to skip it, then you’re starting to build sand castles in the mud. Do the foundation first.

1 Like

The visible grid points in the picture kinda made me wonder. It seems everything has an arrow too. But, yeah, no squares.

C1, C2 & D6 are not Kicad symbols. Maybe all the symbols with a red warning are imported?

You will find most basic symbols in the Kicad “Device” library. Try using those and see if you get warnings.

There is also a PWR_FLAG symbol with a red arrow, and that one is pretty unique t KiCad.

Indeed, that would help. Uploading an archive of the project (Project Manager / File / Archive Project) would make it even easier.

I didn’t bother looking in Ultralibrarian to find out and I certainly wasn’t going to register with them to try importing.


If you are very new to Kicad, this guide will be very helpful.

Thank You hermit

Yes I have changed my grid Setting to 0,0100mm(0,0004 in ) to measure the Footprints Dimensions but currently I changed it to 1,2100 mm (0,0500 in) (default?).

just the symbol C4 isn’t a Kicad symbol.

Thank you jmk!

Just the C4 symbol isn’t a Kicad symbol.

Thank You Andy_P

There are 66 Warnings.
A new user cannot upload a file, therefore I am unfortunately not able to upload an archive of the project, but I can send You the actual Warnings as a picture

Opps. I should have anticipated this. You can upload now.

You are RIGHT paulvdh. Thank You.

As of now I will try to use just the default libraries.

I have got another problem, since I have added a second symbol (no Kicad symbol , from “Library Loader” SamacSys und Mouser )

Thank You hermit.

Thats nice of You :smiley:

Just doing my job. :wink:

Hi paulvdh, here is an archive of the project which I have just uploaded. (30.3 KB)

If I put the capacitance C4 at the circuit, there are 66 warnings. All other symbols are Kicad symbols.

Waauw, over 60 ERC violations because of a single faulty capacitor symbol :slight_smile:

ERC is complaining a lot about the “unspecified” pins of that capacitor to about anything on the two nets it connects to.

I had a look at the datasheet of your (or similar) capacitor:

It is a bit unusual, with 4 legs, but apart from that it’s just a normal capacitor.

Because you intend to use it as a normal capacitor, I recommend to just use a normal capacitor symbol in the schematic, so you do not have to do anything special for the schematic.

But if you want to use that schematic symbol, that’s also possible, but you have to modify it a bit. To do that:

  1. Hover (do not click yet) the mouse over that capacitor.
  2. Press [Ctrl + e]. This loads the capacitor symbol in the Symbol Editor
  3. Symbol Editor / Edit / Pin Table, and then change all “unspecified” pins to “Passive” (Which is what KiCad likes). Then press [OK] to close the pin table.
  4. Close the Symbol Editor. KiCad gives you the options to [Discard changes], [Cancel] or [Save]. Select [Save] to save the changes you made into the schematic.
  5. Run ERC again. Almost all violations are gone. KiCad only complains (and rightfully so) that your modified symbol is not in any library. To fix that you have to learn some library management.

For the PCB footprint, I would just make a copy of a capacitor with a similar size and then add two pads. If you have modified the schematic to use a “normal” capacitor symbol, then you can create two pads with the same number. In that case you will have to connect those pads together on the PCB. If you want to keep your modified capacitor symbol, then number the pads 1, 2, 3 and 4 (in the right order, or you’ll create a short circuit in the capacitor).

Hi paulvdh,

Thank you very much for your helpful information! That solved my problem, As you said, To fix that I have to learn some library management. there is just one warning currently and it depends on the library management if I use the same schematic symbol with four pins.

Thanks again for you useful information!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.