Import project from Eagle


#1

Before I started using KiCad I began a project in Eagle. I would very much like to import what I did into KiCad or at least the schematic but can’t find any way to do this. Do I really have to begin again from scratch? The fact is that the rest of the project has been done in Kicad.


#2

If you have an eagle license (or if the free version is enough) you can try:

Other people are working on such tools as well, but I don’t believe there is any alternative ready yet.


#3

I will definitely try to do this. One problem is that I just installed Eagle 8.00 on my system because I had to transfer my files to my new laptop. It says that you can only transfer files to KiCad from versions 6.00 and maybe 7.00. The project was originally in Eagle 4.15. Do I need to go back to the originals or do you think that the ones in 8.00 will work?


#4

I believe that the scripts will also run in 8.00, but I am not 100% sure on that.

If you are running Windows, you could also try https://github.com/bobc/eakit, but note it is somewhat experimental. Any feedback would be useful. For eakit, you will need to re-save the project in 8.00 to get XML files.


#5

I have tried the first method using Eagle 8.00 but it says “NOT an Eeshema file” when I try to look at the resulting schematic in Kicad. It seemed to be working up to that point. I looked at the properties of the file but couldn’t see if there were any possible adjustments there. I guess I will have to install Eagle 6.00 or use another method. I found my old Eagle license but can’t get the 4.15 version to work on my laptop either. Had a lot of trouble importing the files into a new project in 8.00.


#6

Can you post a few dozen lines of the file so we can see what might be going wrong?


#7

Now I’m really confused. You want me to send you a few dozen lines of the schematic file? How would I do that?

I can’t seem to get it to be a part of an Eagle 8.00 project even when I copy all the project files to the project directory from 4.15. By the way I can’t find any XML files in Eagle 8.00.


#8

Here is the conversion log test. Maybe that’s what you mean.

\#********** START OF renumber-sheet.ulp ULP Version 4.4.4 01-03-2017 :10:31:20 LOG **********#
    Conversion completed with no Messages
\#********** END OF renumber-sheet.ulp ULP Version 4.4.4 01-03-2017 :10:31:20 LOG **********#

\#********** START OF fix_via_hack.ulp ULP Version 4.7.0 01-03-2017 :10:32:00 LOG **********#
\#********** END OF fix_via_hack.ulp ULP Version 4.7.0 01-03-2017 :10:32:00 LOG **********#

\#********** START OF exp-lbrs.ulp 6.8 01-03-2017 :10:40:12 LOG **********#
OK: Eagle lib export from SCH/PCB OK
    Conversion completed with no Messages
\#********** END OF exp-lbrs.ulp 6.8 01-03-2017 :10:40:12 LOG **********#


\#********** START OF eagle-lbr2kicad-1.0.ulp 2.8 01-03-2017 :10:41:01 LOG **********#
Missing Prefix Part =EXPANSION				TEST_EXPANSIONPORT-C64-EDGE					Simple Keyboard Catridge Board B		M
    Conversion completed with no Messages
\#********** END OF eagle-lbr2kicad-1.0.ulp 2.8 01-03-2017 :10:41:01 LOG **********#

#9

I could see in the properties that the new schematic file wanted to start up using eagle.exe so changed that to eeschema.exe so that it is the same as the other working schematic files which I have. If I try to append it into a blank project it still gives me the same error message saying that it’s not an eeschema file.


#10

Did you watch the video for a quick intro, ? https://github.com/lachlanA/eagle-to-kicad
you have to flower the instructions to the letter.

I have not tested my script on 8 of Eagle, the only show stopper was the scripts had a command which
check for version 6 and above, this worked until version 8 came out, now version 8 Eagle just error out when
hit the the check, so I removed it. So give me feed back at https://github.com/lachlanA/eagle-to-kicad
as to any problems, as I don’t monitor kicad.info that much.

Lachlan


#11

No, my connection is too slow. I grabbed a converted project (cmp .kicad_pcb .lbr .lib .mod .pro .sch .scr …etc). How do I load the project into KiCad?

Never mind - save it to a new directory and just open it (plus a bit more).


#13

erichVK5

1m

I have a WIP partially implemented convertor allowing conversion from v4 and v5 Eagle binary files into gEDA layout and gschem schematic formats. v3 binary format would entail slightly more work on the code, but is quite tractable.

I have not yet implemented footprint or symbol conversion yet, as the necessary transformations need to be implemented in the code, but if you’d like the tracks, vias and basic geometry exported to a gEDA PCB layout which can then be exported as a KiCad pcbnew layout from pcb-rnd, put the binary file somewhere and I’ll give it a go.

Regards,

Erich.