I have no preferences>Components Libraries

I have been three days now fighting to complete a 100 pin schematic. So far I have the drawing loaded with all of the parts but one. A cd4007ube Cmos complementary pair IC. Why it is not allready in a library is beyond me.

I found the footprint and the 3d model and downloaded the ones for kicad. From this point everything goes horribly wrong. No matter how many videos I watch not one can get me past this point.

In version 5 there is no preferences > Components Libraries on the drop down box. I have Configure Paths followed by Manage Symbol Libraries. Nothing I have tried works. The files are not even named the same as the videos show. I think I have a version 3 video a version four file and a version 5 program.

This is my third EDA this week I immediatly gave up on Eagle, I could not even get it going. I spent 14 hours drawing my schematic in DipTrace and could not get any further as I could not get the schem to form a pcb. Icould not get any help and it looked like years since anyone answered anything on a forum so I gave up on it and I am trying Kicad now.

Counting watched videos I have over 24 hours in this drawing and I am no closer to finishing this board than when I started a week ago. If I had done this the HARD way and just traced the copperclad with a marker pen and washed the board in chemicals It would be in a box by now, finished. Not as pretty and neat for sure but done just the same.

I have a specific set of components I use and I want to build my own library stuffed with just these parts. Then I should have no more problems with this as there will be no library but the one. But at this moment I do not think that is possible since I can not find any two people that can describe the proceedure it takes to add a component to the library and have it work.

I am afraid to even try the next step. If I get the drawing done it will more than likely take a month to do the next step which I think is annotate the schematic, then process the pcb. Then deal with that. What part is supposed to be better? Is there a way to fix this or do I just give up on EDA’s all together. Is there one that actually works start to finish or do they each only work to a point where thats all you get?

Eagle has become so complicated you need a physics degree just to install and execute it. Someone help me please. This is the stuff that makes people give up on the EDA idea all together. If I had not wasted my life on this software my board would be finished. Why does every EDA have to be complicated enough to build super computers when some of us just want to build guitar pedals or simple power supplies?

So far the only thing it has NOT been is easy. Thank you for your time. I hope someone out there can find an answer for me, this is way depressing and I am losing faith.

You seem to want to make this harder on yourself than it really is.

Open KiCad and clicky the OpAmp looking icon; that if you hover the mouse of the icon tooltips Symbol Editor.

Menu: File/New Symbol
Give it a name and click OK.

Draw a rectangle.
Click the rectangle tool in the right hand tool-bar.
Click on the canvas the starting point of the rectangle
then click on the canvas on the end point of the rectangle.

Click the Add Pin tool in the right hand tool-bar.
Click on the canvas where you want the pin.
Enter the Pin Name and Pin Number in the dialog box.
Click, again, on the canvas where you want to place the pin.
^^^Repeat 13 more times.

Menu: File/Save As.

Please believe me that I have little talent with regards to software, but KiCad is not difficult. I think I was 62 when I first heard about KiCad. This forum is great and beats any other “customer service” which I have encountered.

I will say that some of the keystroke sequences seem a little weird such as inserting a symbol into a schematic; after clicking on the menu command, you then click on the schematic before you get to choose the symbol. The keystroke command is more “normal” but I do not use it often enough to learn that one. These quirks are not big issues.

Regarding the CD4007 I have been a design engineer since 1974 and had not previously encountered that one. I have looked it up; I think it is not popular. Don’t be stuck on the suffix as the symbol may be the same for different package versions.

Also…unless you have a bunch of them or some other reason, I strongly recommend that you try using the SMT version (of most devices) instead of the thru-hole DIP.

Unfortunately KiCad doesn’t have a one-stop up to date tutorial. Trying to use a stone age v3 or v4 tutorial doesn’t work for v5.1.

For library management Rene has written some tutorials in the FAQ section.

I don’t think you should give up. If you get past the first obstacles it gets much easier. I may be partial but this user forum is really good source for help. It of course depends on your needs – how many designs you will ever do etc. – whether it would be easier to do it without an EDA, but if you’re really interested in PCB design and will continue that career or hobby, it’s worth spending some days or weeks to learn some EDA.

This is a more generic problem for newcomers without experience in PCB design. The truth is that even expensive commercial EDA packages don’t cover all the components you need. Learning to create your own libraries and designing your own symbols and footprints is a must. There’s no escaping that. Quite many users even in this forum who have experience with several EDAs and long career can tell you this, and even that they don’t rely on any ready made libraries but design all of their own parts (or their companies have engineers who do only that!).

1 Like

@eelik pointed you to the FAQ but i think i can help you out by pointing to the specific tutorials useful to your current predicament.

You have also to learn to find symbols and especially footprints. For example the footprint for this one is probably DIP-14_W10.16mm in the Package_DIP library. The official KiCad libraries have most of the standard IC and other footprints which are used for several different components by different manufacturers. There are much less footprints in the world than there are parts.

Hi, Sillywan
I’m not sure how far you have progressed.

Have you managed to create your own empty schematic library?
Have you managed to place some components in that library?
Are you just stuck creating a 4007?
Is the problem with your footprint library?


The only library I have is the one that came with the program download. Digi key has the footprint and the 3d model. They even allow us to download them in a supposed KiCad format. Easy right? No its not. for some reason the engineers thought it would be cool to change all of that and rename all the extensions so kicad has no clue what you are trying to do. Nothing fits. Its supposed to be a step file but it is a .pretty file? As to your first question sir I have to be honest. I have no idea at this point what I have done. I have tried for hours to do several things suggested by various videos that have led to total confusion as not one has worked as shown. I do know that I attempted to produce a library as that was one of the suggested ways to finally get the device into a library, but then I reached the click preferences and choose components library issue. So I don’t believe I got it done, but I did try. As to question 2, I get they feeling that if I can get any component into any library my problem will be solved until the next update changes everything again. So no sir I do not believe I have placed anything anywhere that was not already there. Question 3, Yes sir I am definately stuck as I am not sure what you even mean by “Create” a cd4007ube. Question 4, Yes sir, there is a severe problem with my footprint library, It does not include a CD4007UBE. I am sending the version info so that we are all fixing the same issue, I think. I am by no means a software engineer, I have no clue how this stuuf works. I am a 67 year old retired millwright/handyman that played music all his life and has built a few tube amps and guitar pedals the old thru hole hard way.
I mean no disrespect to anyone period but I am just too old to start acquiring tools and equipment to start working with surface mount devices. I consider anything with surface mount devices as built to be disposable. First I do not have a magnification device powerfull enough to even see the devices clearly let alone have a steady enough hand to solder microscopic traces. I am just trying to make it all look good with modern day software. Make the schematics look professional with the correct footprints for the components I used to make the device. I can literally drw the schem out on a sheet of paper like we did in the sixties with just the pinouts to the sockets, but that doesn’t look near as impressive as an EDA print does. The circuit doesn’t care it just works or it doesn’t.

Application: KiCad
Version: (5.1.7)-1, release build
wxWidgets 3.0.5
libcurl/7.71.0 OpenSSL/1.1.1g (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.3.0) libssh2/1.9.0 nghttp2/1.41.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.73.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.71.0
Compiler: GCC 10.2.0 with C++ ABI 1014

Build settings:
Thank you sir for taking the time to help me with this. I have a lot of ideas I want to work out in effort to find the sounds that are in my head and make them audible music wise. Some will never be accomplished unless I get this figured out. Some of this stuff just can’t be done legibly by hand.

Thank you for the resources. I will most definatly research these and keep my fingers crossed that the answer is here. 90 plus percent of the components I work with have been around since the sixties. My reference to the cd4007ube is dated 1992 so it has been around for a while. I am only useing it as the transistor it is replacing is no longer manufactured nor available. So I am useing three pins of a 14 pin device to do what a 3 pin transistor would do. I am replacing a VN10KM n channel VMOS transistor with the chip and I am only using pins 6, 7, and 8.
Anyway thank you I will get right to this as it is understood, I do have to learn how to do this if I am to use KiCad. :persevere:

Hey, Sillywan! Obviously this isn’t the place for a “Who’s the oldest newbie” competition, but I’m also in my sixties and have - like you - just discovered KiCad.

My first reaction is that you have arrived at the right place: KiCad is the way to go, definitely not Eagle. I also tried Tina, but couldn’t get on with that, either.

My second reaction is that you are maybe in too much of a hurry, diving straight into a 100-pin schematic. In my opinion, none of these programs for PCB design can just be used; they have to be learnt first. Unless you are familiar with competing products the learning curve is pretty steep, and there are many basic concepts, procedures, and workflows to get your head around.

Third reaction: trying to learn KiCad by watching vids on YouTube is a flippin’ nightmare! KiCad has undergone a burst of development activity in recent years, and many user interface paradigms have changed (and will continue to change with V6). Menu structures are different, functionality is different. Many of those videos are well out of date.

The solution? Here is what I did: I invested £32 in Peter Dalmaris’s KiCad course, and it is the bet thirty quid I’ve spent in a long time. For that money you get 17 hours of extremely detailed video tutorials, plus a lengthy e-book for you to read when you are chilling out on your settee with a glass of whisky.

It has transformed my ability to use KiCad, and even though I’m nowhere near an expert yet, I feel really confident hammering out schematics, laying out PCBs, making footprints, and so on. You will need to devote some hours to working through the training material, but for me it is definitely worth it.

Start here: https://techexplorations.com/

Good luck with KiCad!

Hi Sillywan,

I’m not a sir. No royalty has yet seen fit to grant me a knighthood, but I live in hope.

Most members of this forum have been using CAD programmes forever and then some, and sometimes tend to overlook the very basics, thereby confusing the absolute newbees. Never be afraid to ask for clarification on a subject.

You are using 5.1.7 I’d suggest, before anything else, you upgrade to the current 5.1.9
You will find it here:

Rene_Poschl (this fellow nearly deserves a knighthood for his contributions to Kicad)
posted some links to excellent tutorials. There are many more.
This one should help you setting up your schematic libraries:
[Creating a new symbol library and a new symbol in KiCad 5]

Hint: make your library “global” so you can easily access your 4007 in your next project :slightly_smiling_face:
Start your new library name with “1a” so it is easy to find at the top of the library list.

You will find lots more instructions in the FAQ link at the top of this forum.

At risk of beating the subject to death…In the mid 1990s I was intimidated by SMT when my employer transitioned to it, and I initially had my technician handle all of that. I have had mild “essential tremor” since I was a kid. For years now I solder 0603 chips and SOT23 chips routinely. Reworking SMT is generally easier than reworking through hole. The only dedicated tools that I can think of as being absolutely necessary are a tweezer, some fine solder, and a fine point for your soldering iron. I recommend starting with the larger chip sizes and avoid 0402 or smaller. You can design and order some small practice boards from JLCPCB inexpensively and try it out. Maybe you can even get some bare scrap SMT boards from someone to experiment on. I recommend using generous size pads for hand soldering; I put 0603s onto 0805 footprints. KiCad has hand soldering footprints but I made my own. Here is an image of my “bigfoot” SO8. Try it and you may wish you had done so earlier.

I live in Washington. Maybe someone can grant you a dayhood or just a hood? :slight_smile:

Hopefully, now you have your own symbol library, you have somewhere to store your 4007.
Probably the easiest way to make your 4007 is to modify an existing, similar drawing. I’d suggest a 4023. It already has the four parts you need.
go into the 4XXX library,
highlight the 4023,
click file save as
change the name in the box to 4007
highlight your personal library in the save in library column.
click save.
You should now have the four parts of a 4023 now called 4007 in your personal library.

Next, you need to modify the four parts to match a 4007.
At the top of your symbol editor page you will see a box with “part A” and an arrow. Click the arrow for the different parts.
Start with part A:
Remove the arc, turn the symbol into a box, delete one pin, edit the other three so they are numbered 6, 13 & 8. Move them 'till you are happy with their position around the box (this is all done with the icons on the right…explore)
Then, back to “symbol properties” at the top of this window and change the “value” etc. …again more exploring.

When part “A” is complete move on to “B”… Same square, five pins this time: 1, 2,
3, 4 & 5. Then properties.

Then “C”: Four pins 9, 10, 11 & 12, properties again.

“D” is correct it is the power pins. You might like to change the box.

Now you have your 4007 schematic.

Sounds pretty good…has a certain ring (or bangle) to it:

Sir Jan the Dayhood from Hopeville :grinning:

A final note on schematic libraries, Sillywan.
Everyone uses them differently.
My preference is to have many personal global libraries to save vasts amount of scrolling and searching.
Some examples:
1aaajkpassive, 1aaajkICs, 1aaajksemis

You will find lots of frequently used schematic components in the “Discrete” library. More exploration necessary. :slightly_smiling_face:

I got the 5.1.9 version installed and confirmed it was 5.1.9 Thank you again for that I am still working on my schematic even if I do not have that component. Every single piece of the schematic is drawn as well as I could figure out with the components I have in my libraries on board. I need to figure out how to set a no connection flag for the nulls and such to get rid of some issues, :innocent: but not bad so far. I have managed to make my first library and get the footprint for my 4007 in there. I have the TI step file but I have not been able to figure out how to make the symbol library part yet. I did take your advice on the library name 1aaadansICs and that is where the footprint is. I did click global but I think it is still tied to the project. No matter, I am just so pleased to get this far. I am currently reading some of Rene’s tutorials on the subject and trying to get the actual symbol in while I give thought to a power source so that warning will go away and the circuit will say pin sevens are energized. I may have to make my output jack switch normally closed instead of normally open. Ihave no idea so far why it is saying that. I did connect a +9vdc power flag to that net. I connected the switch to the power source thru the ground side of the circuit which closes when the male jack is inserted and closes the switch. More thinking but progress is happening and that is much more gratifying than a dead stick every time. Enjoy your weekend, Thanks again :grin:

That goes double for switching power supply design, eelik. Custom magnetics (transformers and inductors) are the rule, not the exception.

Good morning everyone. I have a lot more hours under the hood of KiCad now and yeah it is pretty intense. I took all of the advice and worked my way through it. Most of it helped a lot. I still have a problem hitting the ball but at least I am in the batters box and out of the parking lot. I did buy a book. Even though it is a bit old as reference goes these days it is written for version 5. KiCad Like A Pro, by Peter Dalmaris. I pretty much made it thru until I reached the step to open pcb new. From that point things did not look the same. I am doing the breadboard power supply project and as I said it was going well but when I got to pcbnew the ratlines for the output headers did not show up. everything else just not either of the headers. I missed something while drawing them in and it got real crazy after that. I tried going back thru the lesson to find what I missed but no matter what I did the problem just got worse. More errors and disconnected pins. I finally just gave up. I am going to delete the whole project file and start again from scratch. It should be a little less time consuming as I kind of know where things are now. I am hopeing to find where I made my error that started this.
On another note. I was in the middle of the mess when I decided to just draw the traces in pcbnew and I pretty much figured it out except there were a couple of traces that would not connect to the components no matter what. The red trace would literally draw completely around the pad but would not connect at one end or the other. If I got one end connected the other would not. Is there an apparent reason for that to happen?
Anyway thats where I am at the moment. I appreciate all the help, Thanks everyone I’m going to start this ride over and see if I can make it to the finish this time. :thinking:

Mr. Dalmaris will surely help you if there are problems with the book. He has his own channels for that, check his web pages.

Yes. and this is one of the biggest advantages of any decent EDA program.
The global idea is that you draw the schematic first, and then with [F8] put the footprints and netlist into Pcbnew. If you have done this correctly, then Pcbnew knows which pins have to be connected to which other pins and it shows thin white lines (called ratsnest) for the connections you need to make. It also prevents you from making accidental connections by simply refusing to do so.

It is possible to disable this feature (for some special cases) but I do not recommend to do so.
If you’ve made a proper schematic and assigned footprints, and then press [F8] then Pcbnew opens with all the Footprints inside and it knows the connettions and will also show those Ratsnest lines.