I have a problem with freerouter

Hi There , I am using kicad on a MacBook Pro with macOS Catalina and my version of kicad is 5.1.4 , I have installed the latest java runtime environment and layoutEditor as well.

Still I have a problem with the file freerouting.jar…I seem to be doing eth right… from pcbnew I create a dsn file and I can even open it wihen I click on freerouting.jar and it actually does the routing… when I get a message telling me the routing has been completed I can export the file to kicad and see the result which is ok .

The problem is that the board is not showing in the freebooter app so basically I am working blind!! !
Screenshot 2020-03-24 at 13.59.42|690x431

When freerouter starts I cant even see the top menu, when I do click with the mouse the menu appears.

I have a second computer with the same configuration and etc works fine in that computer!!!

I am puzzled!! anyone can give me an answer ??

Sorry I’m using freeRouting on Linux so don’t have any experience with Mac. From what you say it sounds like a Mac specific problem. Or maybe it’s the very old JDK version that build used. Only thing I can suggest is to try the recent release from the maintainer who has taken on development of freeRouting. Be aware that the visual appearance will be different.

1 Like

Thanks for the reply!!!

I followed the link you sent me and finally got it to work !!!

i found i had two different versions of java in my computer and maybe that was causing the problem. I deleted both then installed the new version of freerouting and i also installed the recommended version of java (java 11)and worked fine

I did try to download the version of freerouting that doesn’t need java but it wouldn’t work, when i tried to instal it i kept getting the message that the file is damaged and can’t be opened.

Glad you got it to work.

I think the version that “doesn’t need Java” includes all the needed objects so not dependent on the host system JDK. Anyway I only used the freeRouting jar from the distribution as I have a recent JDK on my system.

Let’s hope the developer makes more progress. The versions floating around were seriously out of date with JDKs.