I gave up on Linux Mint 19 with KiCad [SOLVED]

I’m using Linux Mint 18.3 without any troubles, and now, since version 19 was released, I gave it a try.

The only thing that worked, was KiCad 5.0.0 with flatpak. All other options I tried, failed:

  • ppa nightly
  • ppa v4
  • ppa v5
  • appimage v4 xenial
  • snap (worked, but got v 4.0.4, and I didn’t manage to get a newer version)

The common problem was, that PCBnew crashed immediately, see my bugreport for further informations: https://bugs.launchpad.net/ubuntu/+source/kicad/+bug/1784139

Thanks to timeshift, I’m back on V18.3.

Greets, Karl

Update 1, 2018-10-30: I tried today the Appimages in a Mint19-VM, which worked as expected. I thought, something has changed, and upgraded my Mint 18.3 ot Mint 19. But same thing again: PCBnew crashes in all 3 versions: 4.0.7 (AppImage), 5.0.1 (AppImage) and nightly (PPA). I really don’t want to set up a whole new system. Can anyone help me here?

Update 2, 2018-10-31: found a temporary solution: I had to uninstall python-wxgtk3.0
That also removed the nightly version of KiCad (PPA), but currently I’m fine with 4.0.7 and 5.0.1.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.