I do not know what I am doing wrong

I am trying to open a kicad project and pcb file from github

link: https://github.com/davek184/nt-series/tree/main/nt-980

All I get is errors. One saying I need a newer version of kicad (pcb is 20210228, I have tried all stable releases after that date). The other is a symbol error saying an ‘=’ was expected on nearly all 459 lines for the PCB file itself.

I have tried different kicad builds (testing, nightly, and older stable), I have tried manually installing libraries, I had installed and uninstalled kicad multiple time, I even have the entire project as a zip file from the creator. Nothing works and I have no idea what I am doing wrong.(zipped project file that includes project library: https://github.com/davek184/RandomFileShare/blob/main/nt-980-DK-Hotswap.zip )

does this project work for anyone else? what am I doing wrong during the installation that causes these errors? what version of kicad do I need to get it to open? none of the stable releases I see came out on the date that the pcb file claims.

Thank you in advance

Are you double clicking the file to open rather than opening it from kicad?

Both, neither work but what would the proper way be?

It was created using a nightly (there are .kicad_prl and .kicad_sch files, both of which are v5.99/6 files).

So you will not be able to open it with a stable release. You’ll need to open it with a 5.99 nightly newer than 2021-02-28.

For windows, these are available here: https://downloads.kicad.org/kicad/windows/explore/nightlies
Other platforms differ.

If the nightly still gives you an error, report back what that error is.

This works for me:

paul@medion:~$ git clone https://github.com/davek184/nt-series
Cloning into 'nt-series'...
remote: Enumerating objects: 294, done.
remote: Counting objects: 100% (86/86), done.
remote: Compressing objects: 100% (73/73), done.
remote: Total 294 (delta 46), reused 9 (delta 9), pack-reused 208
Receiving objects: 100% (294/294), 13.72 MiB | 7.08 MiB/s, done.
Resolving deltas: 100% (146/146), done.
paul@medion:~$ cd nt-series/nt-980/
paul@medion:~/nt-series/nt-980$ ls
firmware           fp-lib-table     nt980.kicad_pcb  nt980.kicad_sch
footprints.pretty  gerber           nt980.kicad_prl  plate
fp-info-cache      heavy-9-adapter  nt980.kicad_pro  README.md
paul@medion:~/nt-series/nt-980$ kicad-nightly nt980.kicad_pro 

There appears to be some weirdness with the zone filling though. The Icons for zones on the left toolbar are greyed-out.

Hmm, that’s weird…
I clicked on the icon to add a new zone, I thought, maybe there were no zones defined in this project, and then the zones suddenly filled.

Can anyone else see this?
Would it be worth a bug report?
I’m using:

Application: KiCad PCB Editor

Version: 5.99.0-unknown-daca9d21f2~131~ubuntu20.04.1, release build

Libraries:
	wxWidgets 3.0.4
	libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-84-generic x86_64, 64 bit, Little endian, wxGTK, xfce, x11

Build Info:
	Date: Sep 13 2021 04:12:49
	wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.71.0
	OCC: 7.3.0
	Curl: 7.68.0
	ngspice: 31
	Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:
	KICAD_USE_OCC=ON
	KICAD_SPICE=ON

I was trying nightly builds yesterday and the PCB was still giving me the ‘=’ expected error. After reinstalling on a different drive today, it is able to open the project.
Thank you very much for your help.

I am still getting the odd zone behavior that paulvdh is reporting but it seems to be working okay nonetheless.

Thank you all again.

As also added, the strange behavior went away after I clicked once on the Add a Filled Zone button on the toolbar on the right side.

That’s strange, I can’t explain the = error.

I was hoping by giving you a definitive answer on which version to use, I could at least eliminate one variable :slight_smile: Glad you got it working.

I seem to remember some zone-filling-state bugs that were fixed a few months ago. It’s possible the design was created with one of those versions? Do the zone issues go away if you refill the zones, save the design, close kicad and reopen it?

The zone issue resolves itself when I press the “add a filled zone” like paulvdh had noted. And after saving it doesn’t seem to come back, I’m not sure what it’s doing but as long as it resolves itself I’m not gonna question it.

Thanks again

Pads and zones are hidden in the objects tab of the appearance panel in this design:

Clicking the “add zone” button automatically sets zones to visible if they are hidden.

(note: we don’t recommend checking in the kicad_prl file to your Git repositories partially so you don’t accidentally confuse people by checking in a project with things hidden)

3 Likes

That clarifies things.
So it’s expected behavior of a new feature I did not yet know about.

What about changing the tooltip text of the zone visibility icons on the left with something like:

Zone visibility is turned of in: Appearance manager / Objects