I am not able to import footprint library

Hello everybody,

I am a newby with KiCad.

I am working with the version 8.0.3.

On the web, I’ve found symbol and footprint templates for an STM32 Blue Pill and a 128 x 64 OLED screen. For each of these components, I have the *.lib file for the symbols and the *.kicad_mod files for the footprints.

I’ve managed to import the *.lib files, but I can’t import the *.kicad_mod files.

In the documentation provided, I couldn’t find a chapter telling me what to do.

Can you tell me what to do or where to find it?

Best regards.

Pierre.

Hi Pierre,
normally you just copy that file to one of your user footprint libs or a new footprint lib (if you haven’t one yet).
Main project window → menu Preferences → Manage Footprint Libraries…
Here the paths to folders containing the *.kicad_mod files are specified. Add a new one or look up the folders of existing libs where you can put the kicad_mod. Leave the KiCad supplied libs as they are. With every update they possible will be changed.
After that you should find that footprint in the Footprint Editor and you should be able to link the footprint within the symbol (Symbol Editor).

Maybe it’s just semantics, but you don’t really “import” libraries into KiCad. You just enter entries into the library tables to tell KiCad where your (personal) libraries are. To keep things organized, give some thought to where you want to put your directories.

For schematic symbols you do this with Project Manager / Preferences / Manage Symbol Libraries, and for footprints you do this with Project Manager / Preferences / Manage Symbol Libraries. But there is a subtle difference. For symbols, the file itself is the library, while for footprints, the location (directory) of the file is the “library” and each footprint in that directory is in the library. For more details you can search for sym-lib-table (for symbols) and fp-lib-table (for footprints).

Thank you for theses answers.

I have a global directory: “MaLibrairie” which contains the directories of my two components: “OLED” and “Blue Pill”.

Instead of indicating each of the directories, I’ve given the global directory. That’s why I couldn’t find anything.

I deleted this global directory and added each of the two component directories, and everything was back in order.

When you’re a beginner, you make a lot of mistakes!

Sincerely.

Pierre.

3 Likes