How unlock a segment of a trace {V7.0.10}

I inadvertently locked a small segment of a trace. Not I cannot seem to unlock it.

To unlock a regular component I select it in the schematic then unlock it in the pcb editor. I’ve tried to select different traces on the schematic but no go.

What might I be missing?

Thanks
John

image

In the bottom right of the PCB editor window, there are a series of check boxes labeled “Selection Filter”. If you check the box for “Locked Items” you should be able to select your locked segment.

3 Likes

Thanks, I had to select locked items and tracks. You are a life saver

John

1 Like

Thanks!

I ran into the same problem when I locked a track and this is a much nicer way of solving this than what I did to get rid of it (I used a text editor to remove ‘locked’ from the segment declaration in the .pcb file).

Somehow I managed to never notice the bottom right selection filter settings as I always used the right-click-select. I learn something new every time I use this great product. Time for another donation!

Yeah, the developers are really sneaky about hiding so much stuff in plain view.

I remember when first using Kicad, it was weeks before I noticed all the information across the screen under the work space. :rofl:

Those are in a grey area.

Maybe grey to you, but could just as easily been on the back of the monitor, for all the notice I took at the time. :roll_eyes: