How to turn off zone corner snap?

I am trying to draw adjacent zones on one of my boards but whenever I try to put a corner near a corner of the adjacent zone the cursor automatically snaps to that corner. I can’t seem to find a way to turn this of. Am I overlooking something? It’s actually a very annoying feature…

Am I overlooking something?

Yes, you overlooked the manual. Special section “snapping”: PCB Editor | 7.0 | English | Documentation | KiCad

In short: hold down Shift-key during drawing (or moving, modifying something) switches off the “snap to objects” mode.

1 Like

OK, thanks. I didn’t even realise there there’s a manual :face_with_peeking_eye:
Still I don’t quite understand the snapping behaviour as it only appears to snap on zones that are drawn on the bottom layer of this 2-sided pcb…

object snapping normally occurs only for objects which are on the currently selected layer (see appearance panel).

The routing-work is a special case, there are more snapping options during routing (snapping to pads, vias, track segments).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.