How to set up PCB Design Rules in v 5.0 for using imperial units?


#1

My first PCB design using KiCad 5.0.1 on my Ubuntu 18.04.1 LTS OS. I am trying to setup the design rules from OSH Park, which are in mils (0.001") using their suggestion of entering the values in mils and then change over to metric. However, the online manual, Clause 8 is not up to date and the setup is under Setup not Design Rules. The default rules are in mm and I don’t see anything about changing to Imperial (and back). Someone please give me instructions.
–Thank you, Larry


#2

You have to change the units from metric to imperial in the main PCBNew window and then re-open the settings window. Note, apparently for many measurement input fields can recognize when you use a unit indicator and will (should) automatically convert to the current viewed units.

See this bug report that I entered a while ago that is currently in Triaged status: https://bugs.launchpad.net/kicad/+bug/1789128
It is for being able to switch viewable units from within dialog boxes, and others mention about entering the unit indicator for automatic conversion. Feel free to vote it up if you have a launchpad (Ubuntu/Canonical?) login.