How to rotate footprint at selected point


#1

In footprint editor I select whole footprint and try to rotate it.
It seems then rotation takes place against point at which I press riht-mouse botton to open the context menu, but I can’t place that point at greed and I result with all elements positioned with 6 digits after dot being not zero-s.

How to rotate footprint against 0,0 position?


#2

Are you in the footprint editor or in pcb new?
What version of kicad?


#3

You are right I should inform that I am asking about KiCad 5.0.1.
But info that I am in footprint editor is at the same begining of my post.


#4

I don’t know why, but after one hour brak (with computer swithced off) I just done it without problem. Before I have tried about 5 times and then undo, and so on. I will do some experiments and if I notice what was the source of problem I will write here.


#5

Now whatever scale of view I set, and whatever random cursor position I set the footprint after rotation is at the round positions. The only difference is that now I have just switched the computer on and before I was after few hours of working in footprint editor, but I certainly I didn’t changed myself any global settings.
So I can’t repeat my problem, but as it seemed me being permanent those time I decided to ask for way-around.


#6

Last info here.
3 hour passed and I wonted to rotate another footprint and got the same problem. Reopening KiCad solves it. Unfortunatelly I can’t say anything about the reason, or the way to follow to fall into the same situation to be able to reasonably report a bug.


#7

@Piotr The action in the Footprint Editor is only a little bit unintuitive.

There are three (3) actions that need to be done to complete the rotation.

  1. Select the items by left clicking a box around them.
  2. Place the cross hairs at the point of the desired rotation. Typically this would be at the center anchor point. Note that this is easier to do with a larger grid setting.
  3. Activate the rotation by depressing the “r” hotkey, or through the mouse right-click menus.

I suspect that you are not consistently doing step 2 in the exact same location every time.


#8

I can find some problem with the latest development version, but I can’t repeat it to pinpoint how it happens. The rotation center seems to somehow get stuck sometimes. It’s not matter of time but of doing something.


#9

It is not the problem of the same location but the problem of location being in grid.

I suppose that what you call cross hair I understand as cursor. I am using arrow cursor.
When I noticed problem I was trying tu put it as precision as possible in center. As it not helped I tried to get better precision by increasing the scale so I sow nothing except center (crossing two blue lines). But it helped nothing. Then I have written my first post and went home for one hour. When I comed back and switched the computer on I noticed that wherever I put the cursor footprint is rotated around grid point close to cursor (I have grid set to 0,1mm). I have done a series of 5…8 rotations putting the cursor at random positions. After it the footprint was located in some random position but coordinates of its elements where ‘round’ in sense those were numbers like 4.65mm. But when I had a problem before going home and then after next 3 hours once more then after rotating however I was trying to precisily point the center the numbers become like 4.384652. Normally cursor moves smoothly, but its position in status bar are rounded to grid. I suppose that from some reason cursor position was not rounded during me noticed problem but I din’t thought to look at status bar so I don’t know if just before rotation cursor position there was rounded or not. Of course it could be that it was rounded in status bar, but not in rotation. At the same time if I tried to select any element and move it was done according to grid.
The problem with cursor not rounded to grid I sow previously (not sure if 4.0.7 or 5.0) and it was permanent and visible in status bar. It was fixed, but it looks there could happen something that this fix is ignored.
During these 3 hours I had the footprint editor opened all the time, and opened several footprints from several libraries and done some editions for them (changing pad sizes and locations by manual writeing numbers, and changing lines at silk and crtyd with mouse).


#10

Of course. I have written that it was after 3 hours to inform that I have done many actions and just couldn’t know which was the critical one, specially that my other actions were all time rounded to grid with no problem.


#11

I had the same situation once more. This time I looked into staus bar - cursor position was rounded to grid but rotation done against some 6 digits after point position.
Reopening Footprint editor was enough (I didn’t closed the main KiCad window) to get back to rounded rotations.
I will report a bug. Hope someone can find the reason.