How to rotate all 3d models of TO_SOT-23 in pcb?


#1

Hi, I found that since 2017-05-08, the 3d model of TO_SOT-23 package has been un-rotated, i.e., from (xyz 0 0 90) to (xyz 0 0 0)

However, in my old pcb, all these models are using the old 3D model and they are by default, rotated by (xyz 0 0 90). For example, in my demo.kicad_pcb, there is,

(model TO_SOT_Packages_SMD.3dshapes/SOT-23.wrl
  (at (xyz 0 0 0))
  (scale (xyz 1 1 1))
  (rotate (xyz 0 0 90))
)

How could I modify the whole board to make these 3d models right? I do not want to modify these components one-by-one.

Thanks!


#2

Option 1: update the footprints of the board.

  • open footprint properties of one of the affected footprint. (press e while your mouse is above the footprint)
  • press change footprint
  • select change footprints 'footprint-name'
  • amply

This will rotate your footprints. (You need to manually fix that.)
It will also set back the location of the value and reference fields.

Option 2:
Change the 3d model. (Checkout the repo at the state before the change)

  • clone the repo and set KISYS3DMOD to point to its modules/packages3d directory. (Kicad main window -> preferences -> configure path)
  • find out which commit rotated the 3d models and checkout a commit before this change.

#3

Thanks! Option 1 works rather well. Except that the font size and locations of values and labels need to be re-placed. Thanks, I thought that may be I need to modify the kicad_pcb file by hand.