How to repress selection of a single locked component

Hi! I’m pretty new to Kicad. But so far it’s been easy to learn!

We have a standard footprint that we use for a stack-able PCB, I made a library that contains the part, I imported it to my PCB and locked it, but now I keep accidentally locking it, and every time I do that there’s a popup saying “Hey are you sure you want to do that?” that I can’t get rid of with the Esc key.
Is there a way to repress the selection of that component?

I would also like to define the outline of the board from the outline of this component, cause for some reason I can’t snap lines to it…?

In Altium I would have deconstructed it to primitives, and move the outline to the keepout layer and lock the primitives.

Thanks in advanced!

Can you rephrase this:

Is this the window you are seeing?
image

This window does go away when you press [Esc], and if you check the Remember decision for this session checkbox, then this window will not be shown anymore.

You can also uncheck Locked Items in the Selection filter in the lower right corner of the PCB editor:
image

@hermit Can you bump this user a level so he can post some more info?

I think a better approach is to make a simple project that has just the PCB outline and your connector, and then use that as a template when starting a new project.

For the line snapping, there are several things that influence this. One of the things is that selection of items is (partially) bound to the active editing layer, but also with PCB Editor / Preferences / Preferences / PCB Editor / Editing Options / Magnetic Points I think that some layers, such as the courtyard layer do not create magnetic snap points at all.

Another possibility is to add lines on Edge.Cuts in the Footprint itself.

@paulvdh
Sorry, I mean I keep accidentally moving it.
The window that keeps popping up reads
“Selection contains locked items. Do you want to continue?” And doesn’t go away when you press Esc. (Using Windows)

Where can I find the selection filter?
It’s not in the lower right corner of my editor.

The Edge Cuts was greyed out in the footprint editor. That was the first thing I tried.

Seems to be at basic already. OP has spent some time reading. :wink:

Haha! Yes. Yes I have.

Are you using KiCad version 5.1? You should upgrade to the latest 6.0 if possible, v5 isn’t supported anymore and v6 has much more features and you need to relearn many things later if you move to v6 from v5.

Yes. I am using V5.0
I’m busy downloading V6

This was exactly what I was looking for! Thanks!

So… All my 3D Models are gone. Is that normal?

When did they “disappear”?

The variable substitution name for links to footprints has changed a few times, and I think the directory location of the 3D models themselves also changed for KiCad V6.

Have a close look at both that variable name used in the footprint, and the actual location of the 3D models on your “disk” drive storage media thing. (Whatever the name for these things is now)

Because you told you were using v5 and updated to 6 it’s probably this: 3D models are missing in 3D viewer after updating to V6