How to reduce the clearance between pads and solder mask



I have the following problem: some time ago I received my first ever Kicad-designed PCBs, and I noticed that there is no solder mask between pads for ICs with a pitch of 0.5. The pads are 0.3 wide, which means that there should be 0.2mm or at least 0.15 solder mask area. The PCB design closeup looks like this. The green area vetween the pads is about 0.05mm, so I would like to make it wider.
Dose anybody know how to do that? I opened the board settings an I thought it might be in the solder mask pane. But I set everything to 0, and the PCB doesn’t change at all, even after pressing B to redraw everything.


Does anyone know what exactly the purple / pink area is? I tried to disable the layers one by one, and this zone apparently disappears only if the pads disappear. What is the outline crossing a bit over the 2 pads? How can I change that?

Thanks for any hint.



Soldermask is set at multiple places. In the pad itself, in the footprint and at the project level. (listed in decreasing priority) Setting it to 0 at any place will mean kicad takes the setting from the next lower priority.

And there is another setting. Minimum soldermask width. If there is soldermask with less than this width it will be removed completely.

0.2 only for 0 soldermask clearance which is generally not a good idea. 0 is exactly at the edge between soldermask defined (cutout smaller than copper) and non soldermask defined (cutout larger than copper)
This is a problem because having the cutout coincide with the edge of a copper feature can lead to delamination.
Check your manufacturers requirements for minimum soldermask clearance and set your board to that.

This is a misconception. B is only for refilling zones it does not do anything else.

Without knowing your kicad settings we can not say anything. If you left the colors as default then it should be the soldermask cutout meaning toggling F.Mask should have an effect on it.

Remember soldermask is a negative layer. It defines where the film will not be.


And also the minimum soldermask width. Some manufacturers lack the capability of making soldermask as narrow as 0.5 pitch.


Also called solder mask web, dam or bridge. 0.1…0.15 mm may be a normal safe minimum value. For mask clearance 0.05…0.1 mm is pretty safe. (These are for cheap pcb manufacturers. Remember that these values are for green mask; different colors have different chemical qualities.)


That is the area where the Solder Mask will NOT be; it is an inverted layer, it shows where the Solder Mask will NOT be placed.

Contrary to the previous replies, I recommend a Solder Mask Clearance Global setting of Zero(0) units; note that the result may well be affected by the Fab House selected and the color of the Solder Mask chosen.

I consider this the same as the principle of defining the “finished” hole size for a plated through hole. The Fab House will choose the drill size and plating methods to achieve the final result. If the order were for 2 Black Solder Mask boards, and also 2 Red Solder Mask boards, I would not expect that I would have to change the basic fundamental Gerber files just for changing a specification of Solder Mask color; but apparently (according to the Interwebs it must be true that) some Fab Houses in fact do required different Gerbers for boards of different colors.

The best way, that I know of, to visualize the Solder Mask layer is to change the global Pads to Mask Clearance from settings of Zero(0) to both +/- 5 mils in the board layout editor and viewing all Three(3) results in the 3D Viewer.

Lastly, if you have a STUPID SMALL PART that you plan to hand solder, you probably really do want more Solder Mask to reduce the chance of solder bridging the pins of the STUPID SMALL PART.



Thanks for your reply.

That is the area where the Solder Mask will NOT be; it is an inverted layer, it shows where the Solder Mask will NOT be placed.

Ok, but how is it called in the software?
I am editing the footprint properties right now.
There are 4 areas:

  • Pad clearance, which is shown as a thin line around the pad.
    -> When I change the value, it’s immediately reflected to the footprint, the thin line position changes depending on the value I set.
  • Solder mask clearance. I was expecting this one to change the width of the purple area around the pad. It doesn’t, so I’m not sure exactly what it means. I tried to set it to 0 as you say, but it doesn’t seem to change anything. Is this a bug or am I looking at the wrong parameter?
  • Solder paste clearance. This one works, the width of the paste window changes.
  • The last one is a percentage, I’ll leave it as is for now.

None of the options seems to change the size of the solder mask.
So the only remaining issue seems to be: how do I change the solder mask clearance?




As @Rene_Poschl already descibed:

What version of KiCad are you using? Where this setting is found has changed location recently.



As @Rene_Poschl already descibed:


Soldermask is set at multiple places . In the pad itself, in the footprint and at the project level. (listed in decreasing priority)

Yes, I can understand it is defined at multiple places if somebody says so. In my case, I thought I would make the setup in the footprint, which is the second one by decreasing priority. The reason of this choice is simply because I thought I know where to alter the setup, but if I can do it somewhere once for all, it would also be fine.
The problem: WHERE is this setting? If I open the footprint properties, as explained above, there is apparently no way (possibly a bug) to set the solder mask parameters, it doesn’t change whatever I do in the footprint settings.

I use 5.1 on Windows 10.




File-> board setup…


See figure 3-6 in:

If you have too wide pads then even with 0.5mm pitch you may be have to have no solder mask betwean pads.


Thanks for your reply.

If you have too wide pads then even with 0.5mm pitch you may be have to have no solder mask betwean pads.

Yes, I know that. The thing is that on my previous CAD software, I could have for instance with 0.5mm pitch QFP, width of the pad = 0.3 and width of the solder mask around 0.15.
I got my first set of circuits produced a month ago. They are really nice, no doubt about that, but the problem is that there is no mask between the pads, which is really a problem if 2 consecutive pads are bound by a trace. It makes a ball when soldering, well, it’s not clean.

File-> board setup…

Finally, I think I found where the problem is. I made custom footprints (regular QFN with pads extended just a little bit to make hand soldering easier). For some reason, the default mask clearance is 0.08. As the pads are separaed by 0.2, the remaining solder mask is 0.04, which is way too thin.
The problem is that I didn’t create the footprint from scratch, but used an existing one in which the default pad clearance was set to 0.08, therefore ignoring all other settings.

Thanks for your replies (and your patience)!



I am still thinking in mils. So betwean pads you have 0.2 = 7.9 mils.
Solder mask clearance (I use since always) is 3 mils. Minimum solder mask width = 3mils = impossible.
When got into that problem I was told by my manufacturer that clearance should be minimum 4 mils so my 3 mils is even too little. That is because of solder mask positioning tolerance.
I’m not technology expert but if you are not doing soldermask defined pads then I would not use solder mask clearence smaller than 3 mils. In your case with raster 0.5 I would left at least 9 mils betwean pads (use 0.27 pads instead of 0.3).

When I first time used raster 0.4 (without solder mask betwean pads) I connected consecutive pads.
Since then for raster 0.4 I don’t connect them.