How to make thermal pad connect to GND


#1

I have this pcb that uses a DRV8871, which I set to Housings_SOIC:TI_SO-PowerPad-8_ThermalVias. I need the power pad to be tied to the front CU zone and I would like the two GND pins tied to it as well so that there are less traces, and more thermal dissipation. I can’t figure out how to do it. Any ideas?


#2

I assume you are talking about U2

You would need to connect it correctly in the schematic. (The symbol would need a pin with number 9 that is connected to GND.)

You would also need to select GND as the net for the zone in question.


#3

What is the KLC for a heatsink slug on the bottom? Pin number 1 higher than the pins, or something else (like “SH” for shielded connectors)? Or is asking this question opening a can of worms that isn’t relevant to this thread?


#4

Most I’ve seen use a simple increment, and some Asian vendors even refer to QFN33 packages, which to me, is a better name than QFN32.


#5

Thanks for the Help!

Okay, so the part isn’t in the parts library, so I had to make it. I added the 9th pin and connected it to GND and made sure that GND as the net for the top layer zone, but still don’t see it connected. I reread the nets and refilled the zones and still nothing.

Here is my part:
drv8871


#6

Try running short traces from the pads, then refill.
There can be fill settings of clearance and spoke size that mean nothing connects, and if nothing connects, kicad removes it…

Your green pour also seems to not connect - is it supposed to ? - check it has GND name, and the Zone Default Pad connection is set to Thermal relief. Then try running a trace.


#7

Are you using a footprint with the 9th pad, usually named with “EP”?


#8

Maybe a silly question:
Did you generate the new netlist in EEschem prior to importin it in PCBnew?


#9

And generate a new netlist after changing the symbol


#10

Those suggestions helped a lot. Using a solid fill combined with new netlist solved my problem. Thanks!


#11

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.