How to make more than one connection between same two points

Hello,
Sometimes when dealing with higher currents, the easiest way to reduce the width of a trace is to replace it with parallel traces with smaller width.
Unfortunately, KiCad is not letting me do that. As I draw the second parallel trace, the first trace disappears. How can I override this behavior?
Thanks.

Automatic removal of the old track when a new connection is made is often desirable, but you can disable this behavior via: PCB Editor / Route / Interactive Router Settings / Remove redundant tracks.

2 Likes

That worked.
Thank you.

1 Like

In addition, if you’ve got an answer to your question, make a habit of marking the best fitting answer as the solution:

image

The forum software then automagically ads it as a direct link to the original post and this helps others (when searching the forum for answers) to find answers quicker. For short threads such as this it does not matter much, but for longer threads the difference can be significant (some threads have over 100 posts).

After doing this, you can lock the tracks and re-enable the setting, if you want