How to install BOM plugin on Mac OS X?

This says nothing about installing or setting up the BOM plugin on Mac OS X. I have downloaded the bom_csv_grouped_by_value.py plugin and placed it in Applications/Kicad/contents/plugins and I still get nothing.

I tried running this on terminal :

python “/private/var/folders/gw/2wc3kcqn7msdklf1hxdbyl4w0000gn/T/AppTranslocation/F9E7FBED-F894-4717-9AD4-3683E92DCCD8/d/kicad.app/Contents/SharedSupport/plugins/bom_csv_sorted_by_ref.py” “%I” “%O”

…and get ‘No such file or directory’.

Why does it have to be so hard?

%I and %O are keys for kicad internal variables. If you run the command in the command line then it does of course not have these variables available.

So how do I enable the pugin on Mac OS X?

All BOM scripts are meant to be run from within the BOM dialog of KiCad. So the question is what is the reason you do not use that? (What is the step that does not work there)

I get this error when I run a plugin:

> Run command:
> python “/private/var/folders/gw/2wc3kcqn7msdklf1hxdbyl4w0000gn/T/AppTranslocation/926495C7-CCAB-4441-9D62-BD6C0F80BDB7/d/kicad.app/Contents/SharedSupport/plugins/bom_csv_grouped_by_value.py” “/Users/alkopop79/Documents/KICAD/AS3394_board/AS3394_board.xml” “/Users/alkopop79/Documents/KICAD/AS3394_board/AS3394_board”
> 
> Command error. Return code 1
> Error messages:
> Traceback (most recent call last):
>   File “/private/var/folders/gw/2wc3kcqn7msdklf1hxdbyl4w0000gn/T/AppTranslocation/926495C7-CCAB-4441-9D62-BD6C0F80BDB7/d/kicad.app/Contents/SharedSupport/plugins/bom_csv_grouped_by_value.py”, line 54, in <module>
>     net = kicad_netlist_reader.netlist(sys.argv[1])
>   File “/private/var/folders/gw/2wc3kcqn7msdklf1hxdbyl4w0000gn/T/AppTranslocation/926495C7-CCAB-4441-9D62-BD6C0F80BDB7/d/kicad.app/Contents/SharedSupport/plugins/kicad_netlist_reader.py”, line 444, in __init__
>     self.load(fname)
>   File “/private/var/folders/gw/2wc3kcqn7msdklf1hxdbyl4w0000gn/T/AppTranslocation/926495C7-CCAB-4441-9D62-BD6C0F80BDB7/d/kicad.app/Contents/SharedSupport/plugins/kicad_netlist_reader.py”, line 742, in load
>     self._reader = sax.make_parser()
>   File “/private/var/folders/gw/2wc3kcqn7msdklf1hxdbyl4w0000gn/T/AppTranslocation/926495C7-CCAB-4441-9D62-BD6C0F80BDB7/d/kicad.app/Contents/Frameworks/Python.framework/Versions/2.7/lib/python2.7/xml/sax/__init__.py”, line 93, in make_parser
>     raise SAXReaderNotAvailable(“No parsers found”, None)
> xml.sax._exceptions.SAXReaderNotAvailable: No parsers found

Quick google search revealed

I am confused about the workaround. Please tell me, what’s the point of this forum if I can’t ask something? Why the hostility? What do I have to do to get help? Is there anyone else I can talk to?

Also, the repo is closed and I can’t comment, therefor I can’t ask for help there.

Lets put it simple: I have no idea about Mac stuff. All I can do is point you do resources of someone else until somebody comes along that knows this stuff. The error message on that report was the same as what you have so it is a start. With a bit of luck the thing i point you do helps. If not then you at least know more and can give whoever comes later more detail.

Thank you. The link you shared me points me in the right direction. Stay safe!

FYI, this issue is tracked in https://gitlab.com/kicad/packaging/kicad-mac-builder/-/issues/227

1 Like