How to import 3D model and connect the one within the Footprint?

Hello, Dear Friends!

It is strange - can not find the clear instructions how to do that.
Where is ? :wink: Can you tell?

We (with the kids in our Remick.School) now can make new 3D model of components
in FreeCad, can make new component and its footprint in KiCad - BUT -
we can not import 3D model in KiCad and - to connect it with its footprint.

We have found the info in Yuotube - but it is old.

Where we can read the true instructions step by step - IN KiCad Documentaion?

Thanks in advance, Alexey Batin and Kids ;).

I didn’t read any instruction for that.
When in footprint editor I have specific footprint selected and then I select menu: Edit->Footprint Properties (or simple tool-bar icon) then I have 3 tabs: General/Local Clearance and Settings/3D Settings. In 3D settings under 3D models box I click [+] and then enter there the 3D file (*.wrl) with its full path.
I decided to not modify KISYS3DMOD so if I use one of original KiCad 3D models I have it with ${KISYS3DMOD} at the beginning and for myself made models I use full path.

1 Like

If you click on: “Help / Pcbnew Manual” you get the manual for Pcbnew.
(If you have the documentation installed)

You can also find the documentation at:

1 Like

If you want to make a 3d model, you should use FreeCad. There is a python plug in for FC that will import/export to Kicad. It works very well.

Create the model in FC, export to Kicad.
Open the kicad footprint, edit it and there is a tab for the 3d model link.

There are other posts on this forum with more details on the “python kicad workbench” for Fc. Search for those keywords.

1 Like

Thank you!
And where can we find this plugin for import model from FC to KiCad?

Kids (and me :blush:) are using FC to make new model in 3D in FC - it is really fine and simple.

But then - can not find the fine step by step instructions in KiCar Doc how to import and connect with footprint.

We find old video at YouTube, but in it there is the info to convert from FC format WRL to STEP, but when we append this STEP file to the properties if ootprint - we see the problem with the scale…

Help :blush::heart_eyes:!

We need with kids the simple step by step instructions to include our new 3D models that we made in FC up to the info in DataSheets of new components - in KiCad in footprints of these components.

Thanks in advance.

Thank you.
You did that without preCovert to STEP format?

Within STEP - we have the problem with the scale - model from FreeCad we see in footprint is too huge…

Thank you, but we can not finger info in Doc about import 3D models from FreeCad to KiCad footprint.

Where? Do you show, please?

I know nothing about 3D file formats. I have never needed any 3D software. I sow info about FreeCAD when I first time installed KiCad (about 3 years ago). Someone here, at forum, told me that (because of something I don’t understand) it is better to give *.wrl files to KiCad footprints. All standard KiCad footprints if they have 3D model then *.wrl file is linked. There are also *.step files in KiCad 3D library and I was told that if *.step file is better to use than KiCad just searches for .step file with the same name.
About year ago I first time tried to do something with FreeCAD and when had a problem (to get more than one color exported to KiCad) I asked at FreeCAD forum, but later I found that if the 3D model for KiCad is a subject it is much better to ask here at KiCad forum. Now I am able to do 3D models I need but I am not an expert in it and as between one model and the next few moths passes I always have to learn from begining :frowning: .
Install KiCadStepUp addon to FreeCAD and among many functions (I have used only 4…5 of them) you have a button to export your model to KiCad files - it takes care of everything. During export it asks several questions - I always accepted defaults, as except changing colors I don’t understand others.
Added later:
But, as I remember, the scaling problem is with *.wrl files and not *.step files. So I suppose you have something wrong with your .step files or may be in KiCad footprint you have some settings not equal to 1 or 0 respectively. I don’t know why but it is told that those settings (except one, I don’t know which) should be 1 or 0, so I do FreeCAD models to be right positioned and in right scale to not using offsets, rotations and scaling in KiCad footprint definition.

1 Like

In FreeCAD you want to open up the addon manager (in the Tools menu) and look for the KiCadStepUpMod workbench:

(Screenshot from FreeCAD: 0.19.23074 (Git), a 0.19 nightly that is a couple weeks old by this point)

KiCad Step-Up takes care of this by generating both a .wrl and a .step file for each footprint that is scaled and located such that the 3D object import in KiCad has a scaling of 1 and a placement of 0,0,0 (x,y,z).

1 Like

Thank you!!!
It is enough!

Best regards.

Thank you very much!
I think we shall overcome now :)!!!

Waiting for next questions… :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.