How to grab (G) wire into position too close to other component temporarily (ignoring clearance)?

I changed other people PCB into a bigger trace width. Everything is not in conflict (too close to each other). I can’t do any grab (G) with mouse because it is now too close to other wires or landyard. So, after release, it would be restored.

But I would like to disable this temporarily and able to move some wire and organize it to make it conflict free later.

It sounds to me like maybe you are not using the selection filter?


I used it and it allowed me to move / grab the wire by the mouse.

When some part of the wire make other component get highlighted like this :framed_picture:, it failed.

Notice I want to move the upper part, but the lower part already conflicted.

I ended up reducing the clearance to 0 mm. I can move the wire but cannot be sure if my move is in good clearance or not. So, this thread is not solved yet.

PCB Editor/ Route / Interactive Router Settings, and then set it to Highlight collisions and Allow DRC violations


But this is an area where KiCad needs some refinement. Just having DRC clearance violations often prevents KiCad from moving a track at all. But also, KiCad is getting improvements in this area, and the KiCad V7.0.7 I am using now seems to do this noticeably better then the older KiCad V6. In KiCad V6 I sometimes dragged a (correct) track into a track with a clearance violation and that made it jump out of something else’s clearance. In KiCad V7 it happens more often that a track moves out of the clearance violation by just starting to drag it, but the interactive router gets confused if there are too many clearances it has to keep track of.

1 Like

That’s it!
Thank you. It at least make it easier to “refactor” the routes. I will try if I found any hurdle with the newest KiCad.

I’m glad this community is active.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.