How to get rid of sharp corners around pads with thermal relief in version 7?


I found an issue regarding zone filling in version 7:

By adding ground plane on a layer in KiCAD 7, we can see sharp corners around pads which have thermal relief.
However, there were smoother corners in KiCAD 6:

Could anyone explain that it is a bug on new version or there is a way to solve this issue?

Are you sure this is really an issue? The usual manufacturing tolerances are way larger than these tiny corner radii and the way PCBs are etched/manufactured will smooth corners out a little bit anyway.

I think in the settings there is an option to enable the old zone filling algorithm, but I wouldn’t deem it necessary here.


Hi Jonathan,

Good point!
But sometimes these corners are too sharp, could you please let me know how to back to previous setting.


Sorry, Kicad 6 has this option, which I suppose would have changed the behaviour

but it looks like I got confused an that option is removed in KiCad 7 (or I can’t find it at the moment). It’s then probably not possible to change.

Agree with Jonathan.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.