How to downgrade on linux?

Is there any way to downgrade from 6.0.9 to 6.0.8 on Ubuntu 22.04.? If have KiCAD installed through the official ppa on my Ubuntu and 6.0.9 crashes all the time. apt lets me only install the most recent version:

apt list --all-versions kicad
Listing... Done
kicad/jammy,now 6.0.9-0-202210312014+8da3e8f707~116~ubuntu22.04.1 amd64 [installed]
kicad/jammy 6.0.2+dfsg-1 amd64

Any ideas?

It can definitely be done in apt by specifying the version you want. For example see here: How To Downgrade A Package To A Specific Version Using Apt In Debian, Ubuntu Or Linux Mint |

But I can’t vouch for those particular invocations because I’m on an RPM based system.

Mh yeah, but apt list shows only v6.0.9, so I don’t know what version to specify (as in your link the keyword is much longer than only the plain version number).

sudo apt install kicad=6.0.8

E: Version '6.0.8' for 'kicad' was not found

You have to find the version string by looking in the repository as shown in that tute. It’s possible that 6.0.8 doesn’t exist for your OS release.

In the worse case you could delete all 6.0.9 packages, then download the 6.0.8 ones and install those (from the files, not the repo).

Yep, only 6.0.9 available. Seems like the older packages are deletet from the repo. Only option I see is to compile it from source, but I’m not sure, I want to do that. Crap.

If your OS release was recent, it could be that earlier KiCad versions were never compiled for that release because they predate it.

However I would look into why 6.0.9 crashes for you. Maybe if you edit the thread title, others who use jammy can comment.

I used 6.0.8 until yesterday but updated it. I already opened a bug report at Github but the crashes are so random (while dragging via, while switching layer, while filling zones) I have no idea what to look for.

I’d guess some dependency library mismatch. If other people use 6.0.9 on jammy successfully you could compare the environments.

This is partly a KiCad question, but more a generic packaging question for Linux.

My debian based linux Mint uses apt and according to man apt I can list available versions with:

paul@cezanne:~$ apt list kicad -a
Listing… Done
kicad/focal,now 6.0.9-0-202210312018+8da3e8f707~116~ubuntu20.04.1 amd64 [installed]
kicad/focal 5.1.12-202111050916+84ad8e8a86~92~ubuntu20.04.1 amd64
kicad/focal 5.1.5+dfsg1-2build2 amd64

With monthly updates of KiCad there is always a possibility some nasty bug is overlooked and reverting to an older version is needed. I do not know why the older versions are not kept available in the KiCad repository. Compiling from source should always be possible, but it’s probably a bit too involved for most folks.

I run kicad 6.0.7 on Debian Buster (10.12).

$ apt list --all-versions kicad
Listing... Done
kicad/oldstable-backports-sloppy,now 6.0.7+dfsg-1~bpo10+1 amd64 [installed]
kicad/oldstable 5.0.2+dfsg1-1+deb10u1 amd64
kicad/oldstable 5.0.2+dfsg1-1 amd64

kicad/oldstable-backports-sloppy 6.0.7+dfsg-1~bpo10+1 i386
kicad/oldstable 5.0.2+dfsg1-1+deb10u1 i386
kicad/oldstable 5.0.2+dfsg1-1 i386
I haven't searched for a compiled deb package with 6.0.8  compiled for my CPU (amd64).   I'd suggest asking on ubuntu forums for any kicad 6.0.x compiled for your CPU architecture.

I was also willing to compile a newer version, e.g., 6.08, of kicad, but couldn't find the make file.   (In other words, the build process was way over my head.)

I deleted my ~.config/kicad and ~.cache/kicad and didn’t have any further incidents for now. Dunno.

1 Like

If you want to downgrade to a previously installed version that has now been deleted from the repository, take a look in /var/cache/apt/archives/. If you haven’t cleaned the package cache, you should find it there.

1 Like

Thanks for the tip, but no KiCAD there as well :smiley: But clearing the KiCAD chache seems to have solved the issue anyway.