How to disable red frame with Title etc


#1

Hello there,
I am still doing my first steps with KiCad and it is a great piece of software!
I was using Eagle before and I managed to eliminate most of the Eagle habits with the documentation and google.
There is one thing remaining - I am not able to get rid of the red frame that is an inevitable part of the board (The one with “Title” and all that stuff. I thought that deleting everything from “Page Layout Editor” will solve the problem but the frame is still there. I do not need it for my work. Can you please advise how to either remove it or at least hide it? It does not seem to be controllable via standard layers…
I am sure I am not the only one with this problem and somebody must have answered this already… but I am not able to find it.
Thank you very much!


#2

In PCBNew you can turn it off by deselecting the ‘worksheet’ box in the render panel. (This is on 5.0 rc 2)
.
50

In Eeschema, I think you would need to start with a blank .wks.
@bobc has a link to one here but I haven’t tried it. https://kicad-info.s3-us-west-2.amazonaws.com/original/2X/4/4ecf9d6fa2359b7dd9c3ffb2b4517933c8f21596.kicad_wks

This was discussed a while back in this thread


#3

Thank you John. I will remove the 4.0.7 version and get the latest nightly Windows build as I cannot see the Worksheet option in 4.0.7. Hopefully that should help.


#4

Please read the FAQ about the nightly builds before committing. I have found recent nightly builds to be so much better than v 4 and largely trouble free. However, my work is not mission critical and you need to be aware of the potential problems. That being said I think a full release will be made ‘shortly’ and I think that there are not many significant bugs remaining in the current development nightlies.


#5

My usage of KiCad is also not critical so I removed the 4.0.7, installed the latest nightly and created a new project (to avoid some conversion problems for the old projects).
But it seems that with the latest nightly I am not even able to assign a footprint. The library loading takes like two minutes but then no footprints are offered. I have waited like 10 minutes but nothing appeared. Looks like I need to get back to the old and stable one.


#6

you probably encountering issue related to lib-table when u upgraded from V4-stable to V5-nightly
see this link…
http://www.eevblog.com/forum/kicad/footprint-association-tool/msg1659884/#msg1659884

for your info check these threads related to the upgrade issues… in case you face some more errors