How to create tin plated vias in kicad

As I am new use I can attach only one image please understand

I have attached 2 images in one image, via is covered by the green mask and in one image it is tin plated vias.

Whenever I use default via in kicad software, via doesn’t get tin plated, I want to create tin plated vias in kicad, how to do that?? Please suggest…I tried finding option in vias properties but couldn’t able to find one…Help appreciated!!

I believe the setting you need is ‘Do not tent vias’ in the Plot settings screen. The tooltip for this says “remove soldermask on vias”. Once set you can check the result in the gerber viewer after plotting.


Thank you so much, I will try that next time generating the Gerber …thanks again

1 Like

Also when you order boards , ask for solder plating or they will be bare gold.

Depends on the defaults of the service. I know OSHPark defaults to ENIG (I’m not sure if any other finishes are available, but I think not). Other services give an option.

@Chinmayembedded when ordering your boards if you want the vias to be plated in solder you should request HASL finish. This stands for Hot Air Solder Leveling. AFAIK, one of the most common techniques is the board house will dip the entire board in a solder bath and then use two hot air “knives” to blow off excess solder as the board is pulled out of the solder bath. (I don’t know if that is the only technique, I only have a passing familiarity with board manufacturing based on getting tours of a couple board houses and watching “how are PCBs made” videos on YouTube.) If the board house offers this finish, it will probably be one of the least expensive finishes.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.