How to create gerbers with 0,0 origin in corner of board

My board is complete and I’m getting ready to send it out for fab. My previous software, I could set a corner of the board to be 0,0 in X,Y, and when I would gerber out, my board would would plot out such that 0,0 position was the corner I defined. I’m not finding the same function in KiCad. Here’s what my board looks like in Pentalogix ViewMate (zoomed out). Board is outside the workspace.

Is there an ability to set an arbitrary 0,0 position for the gerber files? (I set the grid zero position, but that didn’t work).

Thank you,

You can also set it to be the visible coordinate origin for the PCB editor view in Preferences → PCB Editor → Origins & Axes.

Note that the internal origin of KiCad isn’t affected by this, for example the saved file has still the upper left corner of the worksheet as the internal origin, so the gerber coordinates/visible coordinates wouldn’t match the kicad_pcb file coordinates.


Grid zero has nothing to it.
Set the “Auxiliary axis origin”.
I used the name from V5 as I am at PC with V5 (Win7 so can’t use V6).
As I see from @eelik post may be it is “Drill/place file origin in V6”.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.