How to connect two "no net" copper zones with vias?

I have two copper zones, one on each side of the board. I want to connect them together with vias to transfer heat from one to the other.
Placing a “no net” via into the zones, causes them to be spared out around the via. Reducing the clearance in the zone options to zero does not help, as the global minimum clearance is still applied.
The zones cannot be connected to GND for isolation reasons!

Is there a way to do what I want?

Is there a way to do what I want?

Yes.
.
.
.
ok. actually you want to know how to do that?

  • doubleclick the no-net-via
  • the via-properties dialog opens
  • on the top there is drop-down-field where you can choose the net for this via from all existing nets in the design. there is also an entry-field named filter. There you a new unique name for this via (for instance: “extra_zone_net”)
  • click OK to close the dialog. (to check if this was done right: select via with LMB-click and look in statusbar for the net-string)
  • doubleclick the zones to get zones property dialog
  • change zone-net to the new created “extra_zone_net”
  • set Remove islands-setting to: never
  • click OK
  • do the same for the second zone
  • recalculate zone-fill
  • this description was tested on v6.0.5

additional sidenote:

I have two copper zones, one on each side of the board

It’s possible to enable copper for top+bottom on the same zone (top left in the zone properties dialog), so you need to draw only one zone. Of course the other parameters for top/bot-zone than have all equal parameters (clearance, width, and so on)

2 Likes

This solves it. Thank you.

One problem with this – when you change the schematic and re-load the netlist into PCB, does your “extra_zone_net” vanish?

One problem with this – when you change the schematic and re-load the netlist into PCB, does your “extra_zone_net” vanish?

ohhhh - I had not tested that point on the original answer. And yes, an “update board from schematic” deletes the newly created “extra_zone_net” → the zone and via now again “no net”-items and are not connected together.

So there are additional steps needed that net-names survive the “update pcb from schematic” command:

  • add an additional footprint with 1 Pad (for instance :PinHeader_1x01_P1.27mm_Vertical from library Connector_PinHeader_1.27mm) to the board.
  • set footprint properties 3x checkboxes (lower rigth) for:
    • not in schematic
    • exclude from position file
    • exclude from bom
  • select the pad in the middle of this footprint (doubleclick), in pad-properties change net-name to “extra_zone_net”
  • now the netname is persistant.

It’s also an option to add a 1-pinhead-symbol in the schematic and correctly attach a wire and a wire-label with the “extra_zone_net”-name. This would be the way for all users who like to have all information the schematic.

additinal finding (if someone is interested): simply creating a short wire (connect to nothing) and a correspoding label in the schematic doesn’t helps. Such a “non-connected wire” is currently not added to the netlist and therefore not propagated to the board

1 Like

A simple workaround is to add a test point to the schematic, and assign a footprint to it with a single THT pad. Then you can give a net name to that test point and connect both zones to that test point to.

Or better (as Andy_P suggests below):
You heatsink connects to something, so make it visible in the schematic and assign a net label to that connection.

Why don’t you want to connect the zone to GND or other common?

I’m building a PoE PD. The heat sink planes will be thermaly connected to the switching MOSFETs on the cable side of a prebuild PoE module (Silvertel Ag5800), that converts the 48V to 12V. The 12V output is galvanicly isolated from the input side.
I can’t connect the heatsink planes to the shield of the Ethernet Jack, as jack and transformer reside on a different board. I only receive the 4 center taps of the transformer.

1 Like