How to collapse all results in symbol finder

Hi,

When I’m searching for a symbol (after pressing A), the results are always all expanded, which makes it difficult to get an overview of which category I’m in, and for which categories results were found, and navigation is difficult when the lists are long. Am I missing something? Is there a way to configure the results to be collapsed by default, or some toggle button or keyboard shortcut somewhere to expand/collapse on demand?

No, you have not missed a setting/option/command, this is a missing feature.
There is already a gitlab issue open (tagged as feature request): Symbol/Footprint Editor: Add expand-all & collapse-all buttons/hotkeys to library trees (#8243) · Issues · KiCad / KiCad Source Code / kicad · GitLab , so you could upvote that issue to increse the chance of realization.

Albeit this issue is directed towards the library tree panel a conversion to symbol/footprint chooser could follow later with a second step.

I’m not sure what caused this today - I did some file/system cleaning in prep for end-of-year backup. But, when I booted Kicad and opened an existing project this morning, I got Symbol and Footprint error messages galore…

This has happened several times in the past and I made some notes about fixing it for my preferred organization of the lib’s (symbols, footprints, etc).

The fix results in having all of the Symbol and Footprint folders ‘Closed’ by default in the panels.

The ‘fix’ does come with the downside of Activating/Showing all Symbol and Footprint folders. I prefer not having all of them listed (many that I will never use).

It’s easy to reset Hiding/Visibility, though.

This somewhat also relates to another @lens42 User’s post so, I include a ‘tip’ related to that post.

The Fix option’s:
• Delete the ‘fp-lib-table’ and ‘sym-lib-table’ from the Project Folder

• Delete the ‘fp-lib-table’ and ‘sym-lib-table’ from the Kicad-Preference’s Folder

Listing the Folders (footprints and symbols):
‘Preferences-Manage-Symbol and Footprint Lib’
On my system, the default is to have the some Columns Closed. To show them (thus, the content’s) - Right-Click the Column-Label field and set as desired…

Of course this/these may or may-not help other’s but, it works for me…
see Screenshot