How to add a component to a 'flooded' area?


Yes, a Total Newbie (sort of) to Kicad…

I really tried to get away with my the back layer only being copper/gnd/filled. But now I need to add a small component. The back is already filled, and like the subject says, I’d like to just drop a component in. Even though I was on the copper layer, it put the footprint on the B.SilkS layer, and even though the ‘rats nest’ lines were there, I couldn’t draw a trace (net) from it to anything.

I had moved some components on the top layer before, and noticed that the back fill was indifferent and unaware of the new locations-that is, the fill id not see that something had changed, and ‘refilled’.

Is this the same thing?

Also, I tried to find a way to ‘cut out’ a bit of the back fill to put my footprint in, and found that wasn’t possible/legal. So…

Does any change to a layer with fill(s) require starting over on the whole layer?

I tried for months to get the hang of Kicad, but only when I flew through the 2018 “Kicad like a pro” by Peter Delmaris did I actually get a board far enough to be almost ready for a vendor to make!


Long day so maybe I’m not understanding this.
First. The “B” key refills after you make changes to a plane.
Second. Can you post a picture of what happens when you put the footprint on the back layer? A footprint may have some silk screen components but it should also put in the copper layer components. Is this a Kicad issue library component or something you made or found elsewhere?

I find it hard to understand where your problem is.
If you have filled the backside with copper (Use a copper zone, and not a polygon (which is a graphic element without “intelligence” or net connection)), then you can just put any footprint somewhere in that zone and depress the b shortcut key, and the internal geometry gets re-calculated.

That is indeed the normal procedure. Just place a footprint on a zone and then press b to re-calculate the internal zone boundaries.

This is also normal. The back side of the PCB is indifferent to what happens on the front side. They are two separate pieces of copper and they only interact via via’s or THT pads that go through the PCB. SMT pads and copper tracks on the front do not modify anything on the backside of the PCB.

No. You only have to press the b key to re-calculate internal geometry of a copper zone.

The first (possible) alarm bell is that your zone on the back “is already filled”. Normally KiCad does not fill zones if the zone can not be connected to either a via or a pad from a footprint.

Another possible misunderstanding is the use of via’s. If you only have a single (SMT) footprint on the back, then you can not connect it to footprints on the front without placing vias through the PCB.

I’ve made a simple experiment for you.

The schematic:

And the PCB, with 4 resistors on the front, and 4 on the back.

Now do a few simple experiments:
1). Move R5 and R6 outside of the PCB outline, and then press b, all copper from the filled zone on the back gets deleted because that copper can not get connected to a pad.
2). Move R5 and R6 Back inside the PCB outline and press b again. The zone gets filled, and only the pads that should connect to the zone are connected.
3). Draw a copper track (with x) from pad 2 of R5 to pad 2 of R6. It gets drawn right through the copper zone:

4). Now depress b again. The internal geometry gets recalculated and the track is set free:

5). Because copper zones add “clutter” to the PCB during editing, the internal geometry is usually turned off. You can do that with: PCB Editor / View / Drawing Mode / Draw Zone Outlines. You can also toggle this setting with these two icons in the toolbar on the left.

I suspect you have set up something wrongly in your project.
Repeat the above experiments in the project linked in below, then at least we have a common reference if there is anything going wrong and this reduces misunderstandings. (13.5 KB)

1 Like

As I see such your so extensive answer I think you have to have the source of free time. Can you share please this source with all of us :slight_smile:

In my opinion this is a key problem. Filled zone (no mater if you have its visibility switched on or off) does not interfere with routing new tracks. You can do it like the zone is not there. Zone is recalculated later. If you don’t do it yourself the default setting is to recalculate it just before generating gerbers.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.