How do i no-connect a pin on hierarchical sheet?

Hi everyone. I’m having a small issue with ERC, maybe a bug.

I’m designing an audio dsp/amplifier board, and i made a hierarchical sheet with a power amplifier. I need two instances of them. But one pin on one of the instances should be left unconnected. If i just leave it unconnected, i get an ERC error “Hierarchical sheet pin input_ref not connected”.

So i place a no-connect there. But then i get “Warning: a pin with “no connection” flag is connected”.

Any solution other than ignoring the warning?

I remember seeing a commit about this very recently. What KiCad version are you using?

Application: KiCad Schematic Editor x64 on x64

Version: 7.0.1, release build

	wxWidgets 3.2.2
	FreeType 2.12.1
	HarfBuzz 5.0.1
	FontConfig 2.14.1
	libcurl/7.83.1-DEV Schannel zlib/1.2.13

Platform: Windows 10 (build 19045), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
	Date: Mar 11 2023 03:41:46
	wxWidgets: 3.2.2 (wchar_t,wx containers)
	Boost: 1.80.0
	OCC: 7.6.2
	Curl: 7.83.1-DEV
	ngspice: 39
	Compiler: Visual C++ 1934 without C++ ABI

Build settings:

I’m happy to hear this may have been fixed! Thanks!

You are running a very early and rather buggy version of V7.
You should update to 7.0.10 or even the 7.0.11 rc
10 monthly bug fix releases is a lot of fixes.


This issue was solved after release of 7.0.10, so either wait some days until v7.0.11 is released (see parallel thread about last testing of that version) or install one of the latest v7.0.11-rc testing versions (don’t confuse with the nightly, which are a preparation for v8).

link to the underlying gitlab issue: adding a no-connect to an unneeded hierarchical pin produces additional ERCs (#16397) · Issues · KiCad / KiCad Source Code / kicad · GitLab