How do I choose the right footprint?


#1

I am using KiCad 5.1.2, and following the Getting Started Tutorial. I am having trouble choosing the right footprints for the components. The Assign Footprints dialog does not display images, only descriptions. There is a huge list of choices just for LEDs. I wanted a through hole footprint for a standard 5mm LED. Is there a simple way, or do I have to use FreeCAD as another topic suggested?


#2

For me it is easier to find footprints from PCBNew. Click on add part icon on the right tool bar, 3rd down for my installation.


#3

Ok, I found the LED_D5.0mm footprint and added it to the PCB. It isn’t part of the schematic (no air wire connections). Can I get the same footprint view when choosing components in Eeschema?


#4

I just found the View Selected Footprint button in the Assign Footprint dialog window. Sometimes its the simple things that baffle me. I am trying KiCad as an alternative to Eagle. So far I am liking it very much. Thanks for the reply, MT.


#5

Is this related to this bug:

In the screencapture video I posted there you can see that the preview is not always updated when it should be.
https://kicad-info.s3.dualstack.us-west-2.amazonaws.com/original/2X/5/5737f136776b4a809dc59dd7171bfca83dd8325d.mkv


#6

Not really related. My current issue is not being able to assign footprints when working offline. When opening the Assign Footprints tool, the program reaches out to GitHub (https://github.com/KiCad). I have no internet connection at home, and so an error occurs when loading footprint libraries. Is there some way to make these libraries available offline? I have downloaded the symbol and footprint master libraries zip files. I have tried extracting them into the same directory as the KiCad library and modules folders (C:\Program Files\KiCad\share\kicad). I created an environment variable, but without success (KICAD_FOOTPRINT_DIR C:\Program Files\KiCad\share\kicad\kicad-footprints-master). This entry does not show as a Global or Local variable in the Manage Footprints Libraries window. Any suggestions?


#7

I am able to create list items in the Footprint Libraries, Project Specific Libraries window. I still get the load error when working offline, but the entries that I create are displayed in the Assign Footprints window. The Display Selected tool works for the .pretty folders that I add to my Project Specific Libraries list. I guess this will work for now. There is no problem, when working in Eeschema, adding symbols. Can my Global Footprint Libraries load from a local directory instead of GitHub? I’m going offline until tomorrow. Thanks for any replies.


#8

Have you used KiCad V4 sometime in the past with the same machine?


#9

If the answer is yes then read: I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

And in general: Library management in KiCad version 5


#10

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.