How do I change default sheet size in KiCad 5.x/5.99+?

Hi,

How do I change the default sheet size in EESchema and PCBnew from A4 to USLetter? I looked at a few discussions on this forum, but did not find what I was looking for…

I do not have an A4 printer and no access to A4 printing paper. Changing the page properties manually on every schematic and layout I add gets old after a while, and honestly, I tend to forget to do it some of the times and later have inconsistencies and need to move stuff around. There is nothing in the application preferences or the kicad.kicad_pro template file, which would allow me to change the default (at least not obvious to me).

Is it possible to do accomplish this?

Thanks!

When in schematic view goto ‘file’ then ‘page settings’ and the page size option is in there

What OS are you running on?

I’ve got a file with the name: /usr/share/kicad/template/kicad.pro and it seems likely that file is copied when a new project is created.

A simple way to test this is to:

  1. Find the equivalent on your system.
  2. Baclup that directory.
  3. Open that project file as a normal project, & make some changes & save it.
  4. Close it.
  5. Start a new KiCad project and verify if your settings stick.

[Edit] Oops, that directory is normally readonly, so you either have to (temporarily) change the file attributes, or run KiCad as root.

1 Like

Sorry, just realised you wanted the default not how to change the schematic sheet.
Note to self : must read all of the post!!

Thank you, but that I already know. The question is WHAT do I change in the file to make the sheet size be applied to *.kicad_sch and *.kicad_pcb automatically? At this point I am not even sure it’s possible, since the sheet size inside a schematic file is governed by the setting (paper “A4”) or what have you, but there is no obvious place inside the *.kicad_pro file to set this…

It doesn’t look like you can set a default. Paper size is a sheet property, but not a preference, so it is not stored in the project file (AFAIK).

Maybe you can create a new template project and then create new projects from that? If it works it’s easier than changing the page settings for every sch and pcb, although not zero work.

2 Likes

I just made a copy of an existing project, then changed the papersize in the copy and threw the directories in meld and the only change between those directories is in the schematic itself:

I also made an empty project (with an empty schematic) and it just has 4 lines of text:
image

and it doesn’t even have the paper size info in it.
My closest guess is that it is some hard coded default and this probably makes eeliks suggestion of using a template the closest match.

1 Like

Thank you @paulvdh,

That would take care of the old format.

Any ideas for the new one (5.99+)? It doesn’t look to me as if the schematic and layout files are part of the project template anymore, and now the format of the files is json for project, schematic and layout files.

Thanks!

To use a default sheet size you need to create or have a Page Layout Design File. The design file serves as a template, and within the design file all sheet sizes will be the same.

To use a default sheet size:

  1. Go to Place tab in the KiCad Menu

  2. Choose Append Existing Page Layout Design File.

All sheets created within this file will be of the same size.