How Can I Set Default Hierarchical Pin Text Size?

I want the default size to be 50mils for this block diagram, because I have many connections to fit on the root page.

I am being forced to hand edit every hierarchical pin, as I import it from the hierarchical block schematics.

Oddly, the label text in the hierarchical block schematics is 50mils. But when I import to the root, it comes in at 100mils by default… and I am forced to edit.

Help… the monotony is killing me. Please

two things you can do (6.0.x):

  1. you can set the default text size to 50mil in File → Schematic Setup… → Formatting → Default Text Size. With that said, for me the default was already 50mil and I don’t know why it would come in at 100mil for you…
  2. you can post process all the text at once with Edit → Edit Text and Graphic Properties… Choose “sheet pins” as the scope, and maybe filter to selection if you only want to edit certain sheets.

It may have been set at 100mils, because when I started the schematic, I hand edited the first symbol to 100mils, for readability. I soon realized that I wouldn’t be able to fit all of the connections at that size.

I thought that it would work like most properties, where it retains the last edited values before placement.

So, I hand-edited my subsequent instance to 50mils, hoping for the property to “stick”… but it didn’t.

And I wasn’t able to find where the global parameter was. I’ll follow your instructions to see if I can find the global parameter.

It’s there, I promise :slight_smile:

I’m in 5.1.12. I don’t see “Schematic Setup” under the file menu.

Ah, it’s a 6.0 feature.

In 5.1 you can do Preferences → Preferences… → Click on the “Eeschema” label in the tree → Default Text size.

I don’t think there is a 5.1 equivalent of “Edit text and graphic properties”.


That setting is 50mils. So maybe I’m paying for the “sin” of editing the first hierarchical pin that I placed in the schematic to 100mils. Because it seems that this has stuck.

I’m going to see if the preferences are context sensitive to whether I’m in the root schematic or hierarchical page. Maybe that’s where the property stuck. Not sure. Or maybe it will revert back in the next schematic that I do.

Thanks for trying to help.

Following up:
I logged back into this schematic a couple of days ago.

Magically, the text size was reset to 50mils. I’m not sure why, maybe I needed to exit the entire program, not just EESchema. Not sure.

It’s fixed now. Regardless.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.