How can I place my pad exactly where I need it?

I am making a footprint, based upon the following datasheet : CS-104.pdf (113.3 KB)

I have done the top row of pins (21 - 1) now I am looking to do 2 - 20.


Pin 12 is my first example pin of the second row.

They are 5.08mm below the top set.

I trace down 5.08mm from the center of pin 11, then I want to move 1.905(half of the pin gap width) to the left to place pin 12. I don’t seem to be able to move 1.905. The closest I seem to be able to get is 20.95 (I wanted to get to 20.955) from the origin which starts at pin 1.

Any tips? Is this ‘close enough’?

You have to know the tolerances yourself.

You didn’t tell what KiCad version you are using. In version pre-5 it’s possible to do for example this:

  1. Switch on “Magnetic pads - always” in Preferences->General Settings. (EDIT: in footprint editor it’s under Editing Options.)
  2. Select the Measurement (caliper) tool.
  3. Hover over the pad - it snaps to the center.
  4. Hit the spacebar to set the User Origin.
  5. Select the other pad and open the Move Exactly context menu.
  6. Select “User Origin” for Move Relative To.
  7. Now you can give exact coordinates as if the center of the first pad were the coordinate origin.

You can move also a set of items if you select more than one.

Then there are Create Array and Align/Distribute actions in the context menu. They may be very handy for creating and arranging rows.

1 Like

Helpful thank you.

This is my first time through this process - I hadn’t realised that was what the ‘specificed tolerances’ area of the datasheet references.

It states : X.XXX ± 0.05 – so I am fine that is close enough as it is within the specified tolerance :slight_smile:

I simply set the user grid to whatever grids you need.

So in your case set x grid to 1.905 and y grid to 5.08. (For kicad 4 the user grid settings can be found in Dimension->User grid size)

To use the user grid you need to select it in the top toolbar or in the right click menu.

You can also use the array function of the open gl canvas.

Well I actually tried that, but when I click “user grid” nothing actually happens, I get no option to set my grid size,

you have to set it in Dimension / user grid size first

1 Like

Oh boy!

Perhaps a more intuitive way would be if the user selects user grid, but it’s not set, open that dialog!

I also prefer to (temporarily) set the grid to something that fits the task at hand.
Apart from that you can also center the mouse cursor on a pad (or elsewhere) and then use the dX and dY relative coordinates to align stuff.

Put all pads on the same coordinate (for example by using a course grid), and then use the “move exactly” function to move pads. ( Untested. This is in PCBnew, I’m not sure if it is also in the footprint editor).

There’s certainly more than way way to skin a KiCat.

Maybe this is material for FAQ?

1 Like

Have fun with a component that has more than lets say 10 pads. A lot of clicking. Selecting the right pad from the list of possible pads (as you have many of them on the same place you will get a nice dialog asking which one you want)
And you will most likely need to enter a new value for every pad. And this value is most likely not given in the datasheet (As they most likely give the pin pitch not the distances to one reference point)

So not the best option in most cases.

that at best gives you an approximation. (In kicad v4 the spacebar does not use the grid. In v5 at least the nearest grid point will be used. But if you have a coarse grid you will then be way off.)

For me there are only two good options for making footprints within the footprint editor. the user grid and array tools. (Everything else is just either too much work or not reliable enough.)

For more complex footprints either use stepup or a python script. (the later only makes sense if you make a full series of footprints or if you already have a mostly fitting generator)

As usually, @Rene_Poschl is right, the array tools are a much better / faster / accurate way to draw custom footprint pads.

Here experience (which I’m not expecting you to have yet) leads to a different route than the others have described. I see the dimension 5.08mm and I remember that is 0.2in. I didn’t recognize 1.905mm, but I converted that and got 0.075in. Apparently the SCART specification originated in imperial units on a 0.025in (25mil) grid.

My suggestion would be to make sure the origin (anchor) is centered on pin 1. Change your unit to inches and set your grid to 25mils. Place all your other pins on grid, switch back to metric units and finish your footprint.

Unfortunately, when drawing footprints (especially of legacy parts like the SCART connector) you will likely be switching back and forth between imperial and metric units. Experience will help guide you as to when. Remember that 2.54mm is 0.1in and learn to recognize the multiples (like 5.08mm), So if you see a drawing with lots of features on what appears to be a 2.54mm grid it might be easier to switch to imperial and see what else fits. It might be easier for you to just switch to the 0.6350mm (note it shows 25mils in parentheses when you are in metric units), but I find it easier to count multiples of 25 than multiples of 635…

1 Like

I never position pads with the mouse. I make one, put its xy coordinates in directly, and then use the array tool for the rest. Do this as many times as necessary.

The footprint I sketch out in cad first to get pad centers and to center the part.

It will be nice to use stepup for this. My distro is behind on freecad versions.

Why not then simply use stepup to convert it to a footprint without another point of possible errors?

Well, my understanding is that the new stepup requires 0.17 for the footprint creation bits. Fedora supplies 0.16 and I don’t feel like compiling it.

There is a nightly build repo for fedora.

1 Like

For FreeCAD there also is a downloadable “appImage”. It seems to be a complete FreeCAD 0.17 packed together with all dependencies in a single file.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.