How can I lock pad's relative position in footprint as default

I draw a footprint by myself and put it to PCB board. When I check pad properties of this footprint‘s pad, I find it’s position is not Locked as default。

I check several official footprints. They not have this problem (Their position locked option are checked as default) .

I follow some videos to draw footprint. They didn’t mention about it. I also compared my footprint to official footprint. I still can’t figure it out

official footprint‘s pad position is locked as default; mine is not.

I am really confused about it. Is there anyone can help? Thanks!

version information:

Application: KiCad (64-bit)

Version: (5.99.0-11602-gfaa1ff4ec6), release build

	wxWidgets 3.1.5
	libcurl/7.74.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 17763), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
	Date: Jul 31 2021 21:00:07
	wxWidgets: 3.1.5 (wchar_t,STL containers)
	Boost: 1.75.0
	OCC: 7.5.0
	Curl: 7.74.0-DEV
	ngspice: 34
	Compiler: Visual C++ 1928 without C++ ABI

Build settings:

Not sure in 5.99, but in the current (5.1.x) version, I think that’s handled through the footprint properties, and not the pad itself. In the footprint editor’s toolbar, to the right of the Zoom buttons, you have the Footprint Properties dialog, and in the “Move and Place” section, you can select “Free” (selected by default) or “Lock footprint”, which is what I believe sets all pads to locked.

It seem there is no “Move and Place” section Footprint Properties in v5.99, but v5.1.x have.

Footprint Properties in v5.99

I think you are right.
Hmmm, maybe it’s a TODO item.

Threre’s also


Can’t be this one. It’s unchecked.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.