How can I fix these types of warnings easily

Warning: Footprint ‘SOT-23’ does not match copy in lbrary ‘Package_To_Sot_SMD’

I’m also getting a bunch of Symbol ‘2N7000’ has been modified in library ‘Transistor FET’

This all occured as I transitioned over to KiCad 8.0

You have at least three different options.

  1. PCB Editor / Tools / Update Footrprints from Library to use the new “improved” library version of the footprint.
  2. PCB Editor / File / Export Footprints to (new) Library to create a (new / project specific?) library from the footprint version that is already in the project. Do note that you also have to update the footprint links in the schematic with PCB Editor / Tools / Update Schematic from PCB.
  3. Just disable the warning itself. You can do this in various ways by right clicking on a violation in the DRC window and choosing one of the options. You can also do this directly in the board setup.

The option that suits you best depends on your personal preferences and workflow. I guess these warnings are mostly important for people working with database driven, or otherwise verified libraries, and for them it is an important message. If you are working on a hobby level or per project free-lance then this warning may be more bothersome (and distracting) then it’s worth and disabling may be the best option. Also note that it’s easily reversible if you disable the warning, so you can revisit it at a later time (Maybe put it on a checklist to do before creating and sending out Gerbers).

1 Like