How can I add curved filled zone?

under the tool and options from right mouse middle click it does not look like you can add in any way curved shapes, am I wrong?

you are right for the current kicad v6.0.x-version. The “Create from selection”-tool has some restrictions regarding curved segments (bezier-shapes).
For the v6.99 development-version (kicad nightly) there was recently an addition adressing this topic: Bezier shapes aren't considered in the Create from Selection tool (#12778) · Issues · KiCad / KiCad Source Code / kicad · GitLab

(not tested for myself)

It’s not an elegant solution but, rather a ‘common-sense’ solution.

Recognize that short-straight lines viewed on monitor is misleading and will form a smooth-enough edge for Zones. I didn’t bother too much for this example.

  1. Set the Grid to a reasonable value or use Hot-key to Not-Snap
  2. Place a Curved reference for tracing (or, draw free-hand)
  3. Trace/draw the curve

Create the Zone and Fill it (menu items are out of video’s view, sorry about that…

I used the Default settings in the Zone panel and I pre-placed a circle for tracing…


In the screenshot below, I generated gerber files from a project where a GND zone is clipped by an arc in the PCB corner.

As you can see in the screenshot, KiCad generates line segments in the gerber files.

You can influence the coarseness of this approximation with: PCB Editor / File / Board Setup / Design Rules / Constraints / Arc/circle approximation by segments

In the second screenshot I changed it from (probably the default) 0.005mm to 0.1mm

Also note that when you’re working on your PCB, KiCad can show an extreme magnification of your PCB. The “sharp corners” of these approximations are also both rounded very slightly and obfuscated a bit by solder mask. The machines with which the PCB’s are made also have a finite resolution.

Not sure if this helps your use case, but when I wanted to keep gnd plane out of a screw notch, I just added a little pink semi-circle to the margin layer:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.