Hotkeys Don't Work

HI, I’m new to Kicad. I like the suite. All in all it’s very functional with few quirks. The problem I’m having is the only hotkeys that work for me is W, G, and a few others. Any command that requires Shift, Alt or Ctrl do not appear to work.
I’ve scoured the help file and haven’t found an answer. Can anyone help?


What’s your OS and (if it’s linux) window manager. Also post kicad version info from about dialog.

Sorry, forgot to mention my system. I’m using Ubuntu 18.04 LTS and Kicad 5.1.4.

The commands with shift in front typically only select the tool. You then need to click to get the action performed.

All the hotkey commands are grayed out in the drop down menu.

Could you make a screenshot of what you see? I am not certain i understand what you talk about.

The hotkey commands are a light gray. Maybe it’s just my desktop

color scheme

These are always shown in gray. And as i said all of tem just activate the tool you need to then click to get something done.

However take a look under help->list hotkeys as this lists the true immediate action hotkeys.

Mine also shows the hotkey commands in grey.
And in order to select the tool “wire” I only press “w” without “shift”. Furthermore if I press “b” afterwards, nothing happens. I need to press “esc” to exit the wire mode and then press “b” to enter the bus mode.

But if I press “q” or “j” a no-connect flag or juntion dot are placed without the need of pressing “esc” before. Maybe it is in the documentation, but anyway it is an odd behaviour.

1 Like

Doing some experimentation, pressing ‘A’ without Shift brings up the part library. This is true for Bus, Polyline and the rest of the commands. Mystery solved. I’ll just chalk it up to software quirks. Compared to OrCAD, this is really not a big deal.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.