Hollow lines in footprint editor


#1

I have the latest (nightly) build. In the footprint editor, lines that I draw are hollow - rectangles with rounded ends. I can’t find anything in preferences or settings to fix this. Any ideas?


#2

That certainly sounds like the “Outline Mode” in PCBNew (see atch),

but I’m not aware of anything like that in Footprint Editor. What KiCAD version are you using?

Dale


#3

Thanks - that looks EXACTLY like what I see, but those settings (in layout) do not affect the lines in the footprint editor, and I don’t see similar settings in the footprint editor.
This happened when I installed a new (nightly) version a couple of weeks ago. I just installed the latest nightly version and it didn’t change. I’m starting to think it was some bug with the update because I updated from an old version, probably 6 months old or so.


#4

The screenshot I posted came from PCBNew in KiCAD release (2017-02-10 revision 1BCBBB4). I couldn’t find any way to make the “hollow lines” in Footprint Editor.

Do you get the same result in both Legacy Canvas and OpenGL? It’s grasping at straws, but can you try a different graphics driver?

If it’s a bug in the nightly builds then it definitely needs to be reported. (They should be getting close to a major release.) But I’d be reluctant to submit a squawk unless somebody can confirm the problem.

Dale


#5

What happens if you play with the buttons in the left tool bar?
(The screenshot is from 4.0.2 other versions might have different buttons.)


#6

I think you found it! But the behavior is inconsistent between the graphic engines.

Classic:

OpenGL:

Dale


#7

In “Legacy” view I can get solid lines, using “Show Edges Sketch” on the left side. But in Open GL and Cairo views, the lines are always in outline mode. I normally use OpenGL view, but I’ll try to keep it in Legacy view for now. Still, this is different than it was previous to my latest update a few weeks ago. everything works otherwise, so I won’t report this as a bug. I’ll wait for the next major release and see what happens. Thanks.


#8

I think the footprint editor ACTs on the settings of PCBnew.
Close the FP editor, change the settings in PCBnew and then try the FP editor again…